Bug 29331 - Require Ant 1.5.3 for builds
Require Ant 1.5.3 for builds
Status: RESOLVED FIXED
Product: www
Classification: Unclassified
Component: Builds & Repositories
3.x
All All
: P1 (vote)
: 3.x
Assigned To: Michal Zlamal
nbbuild-issues@ide
http://mirrors.theonlinerecordstore.c...
:
Depends on: 24489 31902 31963
Blocks: 26676 26691 29337 31618
  Show dependency treegraph
 
Reported: 2002-12-05 16:45 UTC by Jesse Glick
Modified: 2003-12-11 14:24 UTC (History)
4 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2002-12-05 16:45:00 UTC
NB now includes Ant 1.5.1. Everyone is using it.
The NB build supports it, yet assumes 1.4.1 as the
baseline. Why?!

- 1.5.x supports debuglevel attr on <javac> which
we need

- XML tasks can use catalogs, enabling us to
discard org.netbeans.nbbuild.XMLValidate, use
<style> offline, etc.

- many other bugfixes and improvements which we
cannot take advantage of currently
Comment 1 Jesse Glick 2003-01-07 01:09:24 UTC
FYI - we now have blanket approval for using Ant 1.5.x throughout NB
wherever we currently use earlier releases.
Comment 2 Jesse Glick 2003-01-13 16:22:28 UTC
Any status or plans for this? Does it sound reasonable? Are there
non-obvious dependencies on Ant 1.4.x somewhere?
Comment 3 Michal Zlamal 2003-01-13 17:07:01 UTC
I'm doing testing. If all go good we'll switch.
Comment 4 Jesse Glick 2003-03-12 19:56:31 UTC
Seems SignJar changed signatures again, need to patch MakeNBM. Now
setKeystore takes String while setSignedjar takes File.
Comment 5 Jesse Glick 2003-03-12 19:58:30 UTC
Filed the SignJar problem separately as that should be fixed for 3.5 -
i.e. in 3.5 it should be *possible* to use Ant 1.5.2 (with 1.4.1 the
supported version) whereas in the trunk it should be *required*.
Comment 6 Jesse Glick 2003-03-27 16:34:49 UTC
It seems <style> is badly broken on 1.4.1 also for some cases where
the stylesheet uses entity includes which use relative paths going to
near the root of the Unix filesystem. Apparently fixed in 1.5.2;
possibly Ant bug #6259, possibly something else.
Comment 7 Jesse Glick 2003-04-09 20:32:56 UTC
FYI - 1.5.3 is in beta.
Comment 8 Jesse Glick 2003-04-09 20:45:35 UTC
My mistake, 1.5.3 is already released.
Comment 9 Michael Ottati 2003-05-07 17:16:14 UTC
In the future is it possible to keep the build ant version 
and the ant version that we ship with the product 
consistent?

With the way we are doing it now (the build scripts lag 
the product), it seems like we could get into a situation 
where ant scripts that work inside the IDE would not work 
outside the IDE and visa versa.
Comment 10 Jesse Glick 2003-05-07 17:49:15 UTC
I agree that consistency between the bundled Ant and that used for
builds would be desirable. But first priority for each is making them
be current. IMHO NB dev sources should support any new stable Ant
releases within a week or so of its release, a month at the outside.
This could probably be said of other libraries too of course. Anyway
that is all a broader topic suitable for nbdev but somewhat out of
scope here.
Comment 11 rbalada 2003-05-09 17:23:39 UTC
Michael,
such inconsistencies are not only in our hands. Apache Ant is well
known for introducing huge incompatibilities between releases ;-( and
also turnbacks in further releases.

I agree with Jesse, that keeping consistency is desirable, but not
feasible with current Apache Ant's developers approach to backward
compatibility.
Comment 12 Jesse Glick 2003-05-09 17:39:07 UTC
To clarify: the Ant project definitely pays attention to compatibility
of build scripts, and generally also to custom tasks. However NB has
some tasks which either (1) do bizarre things with the Ant core such
as dynamically add targets to a build, or (2) directly refer to the
implementation classes of existing tasks.

Such dumb tricks are not generally supported, so we sometimes need to
do a bit of work to upgrade the build system to a new Ant release. I
would not call them "huge incompatibilities"; most commonly a
parameter changes from String to File or something like that. An
hour's work for a programmer maybe. (In this case, the 1.5.3 support
work is already done I think - we only need to *require* the new
version rather than merely *permit* it.)
Comment 13 Jesse Glick 2003-05-14 21:08:35 UTC
Progress report please? This has been open for half a year. In the
meantime I am wasting time trying to work around Ant 1.4.x bugs which
have already been fixed in 1.5.
Comment 14 rbalada 2003-05-15 08:45:29 UTC
Here's the report (for NetBeans product):
- NetBeans daily production dev build is almost ready,
  doing final test build (future dev build #200305150700 is going
  to be built with Ant 1.5.3)
- NetBeans continuous build needs update (dev, release35,
  prj40_prototype), probably it would be enough to recognize
  whether it's release35 or other branch
- NetBeans features update build needs update (I expect just test
  build would be enough)

Comment 15 rbalada 2003-05-15 12:42:37 UTC
I've forgot to mention, that the referenced build 200305150700 is just
test build, even it was run in full production environment, just with
different Ant release. The report was not a promise of any kind. I'm
sorry, if there was any misunderstandings.
Comment 16 Michal Zlamal 2003-06-05 15:00:06 UTC
*** Issue 31837 has been marked as a duplicate of this issue. ***
Comment 17 Michal Zlamal 2003-06-05 15:02:33 UTC
NB build is now switched to ANT 1.5.3
Comment 18 Jesse Glick 2003-06-05 17:26:04 UTC
x
Comment 19 Jesse Glick 2003-06-05 17:32:40 UTC
There was no resolution, correcting.

You forgot to update some web pages in nbbuild.netbeans.org; I will do
that.

Lots of other related stuff to do, I will try to work on it.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo