Bug 29043 - NPE on showing help
NPE on showing help
Status: VERIFIED FIXED
Product: usersguide
Classification: Unclassified
Component: Code
3.x
All All
: P1 (vote)
: 3.x
Assigned To: Jesse Glick
issues@usersguide
:
: 29047 29048 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-27 10:17 UTC by pzajac
Modified: 2003-02-04 14:54 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
exception stack trace (2.21 KB, text/plain)
2002-11-27 10:19 UTC, pzajac
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pzajac 2002-11-27 10:17:30 UTC
NullPointer exception thrown on showing Help
window. Exception is thrown from all places.
Comment 1 pzajac 2002-11-27 10:19:06 UTC
Created attachment 8063 [details]
exception stack trace
Comment 2 Petr Nejedly 2002-11-27 10:27:43 UTC
I thought it is caused by null HelpCtx but that can't be the case.
Reassigning
Comment 3 Jiri Kovalsky 2002-11-27 11:31:13 UTC
*** Issue 29048 has been marked as a duplicate of this issue. ***
Comment 4 Jiri Kovalsky 2002-11-27 11:32:55 UTC
This is very serious defect and should be resolved as soon as
possible. Raising priority since this is gonna be Q-build showstopper.
Comment 5 Milan Kubec 2002-11-27 12:49:23 UTC
*** Issue 29047 has been marked as a duplicate of this issue. ***
Comment 6 akemr 2002-11-27 14:12:35 UTC
Investigation:

Problem occured somewhere between builds NetBeans-dev-20021125-1626
and night build from Nov 26th. There was no change in javahelp module
and many changes in usersguide module. And, if I replace
usersguide.jar (from Nov 26th) with the older one (Nov 25th),
everything works.

Not sure, where is the problem, but probably somewhere in usersguide
module. Reassigning.
Comment 7 Patrick Keegan 2002-11-27 14:36:23 UTC
I made a bad checkin (malformed xml file). Fixed in trunk a few hours 
ago.
Comment 8 Jiri Kovalsky 2002-11-28 09:58:13 UTC
Can you Patrick integrate your fix to QBE200211270100 branch too, so
that after both showstoppers are fixed we can promote Q-build ? Thanks.
Comment 9 Patrick Keegan 2002-11-28 13:58:12 UTC
fixed in QBE200211270100 
Comment 10 Jiri Kovalsky 2002-11-29 13:45:53 UTC
Petre, could you please verify this ? Thanks.
Comment 11 pzajac 2002-11-29 15:00:18 UTC
it seems fine


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo