Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 28294 - Ability to sort method order
Ability to sort method order
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
7.0.1
All All
: P3 with 7 votes (vote)
: 7.4
Assigned To: Dusan Balek
issues@editor
:
: 151380 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-25 22:59 UTC by _ gtzabari
Modified: 2013-08-10 13:38 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2002-10-25 22:59:27 UTC
We should be able to sort the methods according to 
different schemes. My personal preferance would be:

- Sort by method name (alphabetic) and (optionally) group 
set/get methods together

   I feel this is necessary to guarantee synchronized 
method order between interfaces and classes that implement 
them. Very often the two files go out of sync and its 
difficult to find my way in the files.
Comment 1 markiewb 2012-09-05 17:36:40 UTC

*** This bug has been marked as a duplicate of bug 212528 ***
Comment 3 Dusan Balek 2013-05-09 20:27:16 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/7994ba991395
Comment 4 Quality Engineering 2013-05-11 02:32:35 UTC
Integrated into 'main-golden', will be available in build *201305102300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7994ba991395
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #224245 and #28294: Ability to sort method order - fixed.
Comment 5 markiewb 2013-08-10 13:38:41 UTC
*** Bug 151380 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo