Bug 212528 - Organize members
Organize members
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Editor
7.2
All All
: P3 (vote)
: 7.3
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 12:42 UTC by Ralph Ruijs
Modified: 2012-09-06 14:57 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Ruijs 2012-05-15 12:42:24 UTC
It would be great if there would be a feature to organize the members of a class, following the configuration specified by Editor->Formatting->Java->Code Generation.
Comment 1 Dusan Balek 2012-08-15 08:47:20 UTC
Organize Members action and hint added.

http://hg.netbeans.org/jet-main/rev/5f9d47c0b34f
Comment 2 Quality Engineering 2012-08-21 15:08:45 UTC
Integrated into 'main-golden', will be available in build *201208211308* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5f9d47c0b34f
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #212528: Organize members feature added.
Comment 3 markiewb 2012-09-05 17:36:40 UTC
*** Bug 28294 has been marked as a duplicate of this bug. ***
Comment 4 _ gtzabari 2012-09-05 18:22:57 UTC
Dusan,

I tried build 201209050001 but couldn't figure out how to use this feature.

1. How do you specify the sort order of members?
2. How do you tell Netbeans to sort them? I couldn't find the editor hint.
Comment 5 Dusan Balek 2012-09-06 07:21:14 UTC
ad 1)
Tools -> Options -> Editor -> Formatting -> Java -> Code Generation

ad 2)
Source -> Organize Members sorts members of the class under caret.
Editor hint is disabled by default. It can be enabled via Tools -> Options -> Editor -> Hints -> Java -> Class Structure
Comment 6 _ gtzabari 2012-09-06 13:54:19 UTC
Bug 28294 was closed as a duplicate of this issue, but I believe you're missing the requested functionality. I asked to be able to sort members by name and/or group getters/setters together. I tested the feature and it doesn't seem to support this.
Comment 7 Dusan Balek 2012-09-06 14:57:01 UTC
You are right - Bug 28294 is not a duplicate of this issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo