Bug 268654 - IllegalArgumentException: File cannot be a directory
IllegalArgumentException: File cannot be a directory
Status: VERIFIED FIXED
Product: javascript
Classification: Unclassified
Component: Tools
8.2
All All
: P3 (vote)
: 8.2
Assigned To: Tomas Mysik
issues@javascript
EXCEPTIONS_REPORT 82patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-24 09:02 UTC by emltakeo
Modified: 2016-12-13 14:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.25 KB, text/plain)
2016-10-24 09:02 UTC, emltakeo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description emltakeo 2016-10-24 09:02:51 UTC
Build: NetBeans IDE 8.2 (Build 201609300101)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.101-b13, Java(TM) SE Runtime Environment, 1.8.0_101-b13
OS: Linux

User Comments:
GUEST: dsfg ds gdsg dsf g

GUEST: problems :-D

GUEST: project regeneration

GUEST: i not know

GUEST: <Please provide a description of the problem or the steps to reproduce>asdf

emltakeo: It just occured.
The project was closed. I svn up then opened the project.
It throws this exception and only shows "Please Wait..." under the project in the Projects tree.
I tried to delete the nbproject directory and recreate the project but same error occured.

GUEST: report




Stacktrace: 
java.lang.IllegalArgumentException: File cannot be a directory
   at org.netbeans.modules.web.common.spi.ImportantFilesImplementation$FileInfo.<init>(ImportantFilesImplementation.java:109)
   at org.netbeans.modules.javascript.gulp.file.ImportantFilesImpl$1.create(ImportantFilesImpl.java:63)
   at org.netbeans.modules.web.common.spi.ImportantFilesSupport.getFiles(ImportantFilesSupport.java:107)
   at org.netbeans.modules.javascript.gulp.file.ImportantFilesImpl.getFiles(ImportantFilesImpl.java:75)
   at org.netbeans.modules.web.common.ui.ImportantFiles$ImportantFilesChildren.getImportantFiles(ImportantFiles.java:294)
   at org.netbeans.modules.web.common.ui.ImportantFiles$ImportantFilesChildren.hasImportantFiles(ImportantFiles.java:257)
Comment 1 emltakeo 2016-10-24 09:02:53 UTC
Created attachment 162607 [details]
stacktrace
Comment 2 Tomas Mysik 2016-11-11 07:28:31 UTC
The problem is that you have "gulfile.js" _folder_ (not a file!) in your project. Is this correct/expected?

Thanks.
Comment 3 Tomas Mysik 2016-11-11 07:39:08 UTC
Fixed now. Please verify if possible.

Thanks.

http://hg.netbeans.org/web-main/rev/c879d07c1b81
Comment 4 Quality Engineering 2016-11-12 03:15:46 UTC
Integrated into 'main-silver', will be available in build *201611120001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/c879d07c1b81
User: Tomas Mysik <tmysik@netbeans.org>
Log: #268654 - IllegalArgumentException: File cannot be a directory
Comment 5 emltakeo 2016-11-16 02:00:55 UTC
Hi,

I confirm that the issue is fixed.

Thanks.
Comment 6 Tomas Mysik 2016-11-21 08:04:24 UTC
Thanks for verification.
Comment 7 Tomas Mysik 2016-12-03 14:40:03 UTC
Transplanted to the releases repo branch release82:

http://hg.netbeans.org/releases/rev/b7470852796e

Thanks.
Comment 8 Stepan Zebra 2016-12-13 14:20:22 UTC
verified in NB 8.2 Patch 1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo