Bug 267950 - Test RemoteDevelopmentTest is broken
Test RemoteDevelopmentTest is broken
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
Dev
PC Solaris
: P2 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-09 12:49 UTC by Alexander Simon
Modified: 2016-09-14 06:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2016-09-09 12:49:22 UTC
Test is broken and do not report "failure" status.
See log:
    [junit] Testsuite: org.netbeans.modules.cnd.remote.ui.test.RemoteDevelopmentTest
    [junit] Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0 sec
    [junit] 
    [junit] Null Test: 	Caused an ERROR
    [junit] null
    [junit] java.lang.reflect.InvocationTargetException
    [junit] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    [junit] 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    [junit] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    [junit] 	at java.lang.reflect.Method.invoke(Method.java:497)
    [junit] 	at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.run(JUnitTestRunner.java:405)
    [junit] 	at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.launch(JUnitTestRunner.java:1182)
    [junit] 	at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.main(JUnitTestRunner.java:1033)
    [junit] Caused by: java.lang.NoClassDefFoundError: org/netbeans/insane/scanner/Visitor
    [junit] 	at java.lang.Class.getDeclaredMethods0(Native Method)
    [junit] 	at java.lang.Class.privateGetDeclaredMethods(Class.java:2701)
    [junit] 	at java.lang.Class.getDeclaredMethods(Class.java:1975)
    [junit] 	at org.netbeans.modules.nativeexecution.test.NativeExecutionBaseTestSuite.findTestData(NativeExecutionBaseTestSuite.java:336)
    [junit] 	at org.netbeans.modules.nativeexecution.test.NativeExecutionBaseTestSuite.addTest(NativeExecutionBaseTestSuite.java:141)
    [junit] 	at org.netbeans.modules.nativeexecution.test.NativeExecutionBaseTestSuite.<init>(NativeExecutionBaseTestSuite.java:128)
    [junit] 	at org.netbeans.modules.cnd.test.CndBaseTestSuite.<init>(CndBaseTestSuite.java:114)
    [junit] 	at org.netbeans.modules.cnd.remote.ui.test.RemoteDevelopmentTest.<init>(RemoteDevelopmentTest.java:64)
    [junit] 	at org.netbeans.modules.cnd.remote.ui.test.RemoteDevelopmentTest.<init>(RemoteDevelopmentTest.java:58)
    [junit] 	at org.netbeans.modules.cnd.remote.ui.test.RemoteDevelopmentTest.suite(RemoteDevelopmentTest.java:68)
    [junit] 	... 7 more
    [junit] Caused by: java.lang.ClassNotFoundException: org.netbeans.insane.scanner.Visitor
    [junit] 	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    [junit] 	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    [junit] 	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
    [junit] 	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    [junit] 	... 17 more
    [junit] 
    [junit] 
    [junit] Test org.netbeans.modules.cnd.remote.ui.test.RemoteDevelopmentTest FAILED

For more information see log if hudson test job "cnd-test-solaris10.x86".
Comment 1 Vladimir Kvashin 2016-09-09 14:43:45 UTC
fixed in cnd-main
http://hg.netbeans.org/cnd-main/rev/ee7431b1484b
Comment 2 Vladimir Kvashin 2016-09-09 14:56:22 UTC
*** Bug 267949 has been marked as a duplicate of this bug. ***
Comment 3 Quality Engineering 2016-09-10 02:16:05 UTC
Integrated into 'main-silver', will be available in build *201609100002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/ee7431b1484b
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #267950 - Test RemoteDevelopmentTest is broken


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo