Bug 267949 - Test RemoteDevelopment2Test is broken
Test RemoteDevelopment2Test is broken
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
Dev
PC Solaris
: P2 (vote)
: 8.2
Assigned To: Vladimir Kvashin
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-09 12:42 UTC by Alexander Simon
Modified: 2016-09-14 06:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2016-09-09 12:42:34 UTC
The testsuite: org.netbeans.modules.cnd.remote.test.RemoteDevelopment2Test
is broken due to lack of dependencies and service providers.

We cannot rely on "successful" test status because test log has SEVERE Error.

Please fix warning:
    [junit] INFO: Warning - could not install some modules:
    [junit] 	org.netbeans.modules.editor.lib2 - No module providing the capability org.netbeans.modules.editor.actions could be found.
    [junit] 	org.netbeans.modules.projectui - The module named org.netbeans.modules.favorites/1 was needed and not found.
    [junit] 	org.netbeans.modules.projectui - The module named org.netbeans.core.execution/1 was needed and not found.
    [junit] 	org.netbeans.modules.projectui - The module named org.netbeans.modules.sendopts/2 was needed and not found.
    [junit] 	org.netbeans.modules.editor.lib - The module org.netbeans.modules.editor.lib2 would also need to be installed.
....

And error:
    [junit] SEVERE: Error in RequestProcessor org.netbeans.modules.parsing.impl.indexing.IndexingModule$Startup
    [junit] org.openide.util.RequestProcessor$SlowItem: task failed due to: java.lang.IllegalStateException: No ActiveDocumentProvider instance in global lookup.
    [junit] 	at org.openide.util.RequestProcessor.post(RequestProcessor.java:420)
    [junit] 	at org.netbeans.core.startup.NbStartStop.initialize(NbStartStop.java:87)
....

For more information see log if hudson test job "cnd-test-solaris10.x86".
Comment 1 Vladimir Kvashin 2016-09-09 14:56:22 UTC
Just not enough dependencies after splitting cnd.remote into ui and non-ui parts - the same as in issue 267950 that has been just fixed.

*** This bug has been marked as a duplicate of bug 267950 ***
Comment 2 Alexander Simon 2016-09-12 15:32:19 UTC
Not fixed. The same messages in the log.
Comment 3 Vladimir Kvashin 2016-09-13 12:03:00 UTC
You are right, the reason of this bug was different. Thanks. Fixed in 
http://hg.netbeans.org/cnd-main/rev/6a9afa8d0bd2
Comment 4 Vladimir Kvashin 2016-09-13 15:12:49 UTC
There are still such messages in the log, but tests run, I checked this in debugger and on hudson site. So tests are not broken. Sure we should get rid of this messages. I filed a separate P3 issue 268002 concerning that.
Comment 5 Quality Engineering 2016-09-14 02:06:50 UTC
Integrated into 'main-silver', will be available in build *201609140002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/6a9afa8d0bd2
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #267949 - Test RemoteDevelopment2Test is broken


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo