Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 262749 - Netbeans fails to start Tomcat 8.5.3
Netbeans fails to start Tomcat 8.5.3
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: Tomcat
8.1
All All
: P2 (vote)
: 8.2
Assigned To: Petr Hejl
issues@serverplugins
:
: 262741 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-09 19:02 UTC by jdesmet
Modified: 2016-07-15 01:48 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jdesmet 2016-07-09 19:02:20 UTC
Note that this works for versions prior to Tomcat 8.5.3.

The issue can be simply fixed by modifying server.xml:
add the server attribute in the Connector for HTTP/1.1.
server="Apache-Coyote/1.1"

The problem can be traced back to a matching change in documentation:
https://tomcat.apache.org/tomcat-8.5-doc/config/http.html
"Overrides the Server header for the http response. If set, the value for this attribute overrides any Server header set by a web application. If not set, any value specified by the application is used. If the application does not specify a value then no Server header is set."

Before it stated:
https://tomcat.apache.org/tomcat-8.0-doc/config/http.html
"Overrides the Server header for the http response. If set, the value for this attribute overrides the Tomcat default and any Server header set by a web application. If not set, any value specified by the application is used. If the application does not specify a value then Apache-Coyote/1.1 is used. Unless you are paranoid, you won't need this feature."

This would one lead to suspect that somehow NetBeans uses this server header string to identify that the server has been properly started. It should be possible to do so irrespective of this header.
Comment 1 jdesmet 2016-07-09 19:15:27 UTC
See Following link for a formatted version of this issue:
http://stackoverflow.com/a/38277506/744133
Comment 2 Petr Hejl 2016-07-11 13:21:40 UTC
*** Bug 262741 has been marked as a duplicate of this bug. ***
Comment 3 Petr Hejl 2016-07-14 12:46:11 UTC
Fixed in web-main 44b68bc11b0b.
Comment 4 Quality Engineering 2016-07-15 01:48:10 UTC
Integrated into 'main-silver', will be available in build *201607150002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/44b68bc11b0b
User: Petr Hejl <phejl@netbeans.org>
Log: #262749 - Netbeans fails to start Tomcat 8.5.3


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo