Bug 262677 - AssertionError: isSubtype METHOD
AssertionError: isSubtype METHOD
Status: RESOLVED DUPLICATE of bug 188662
Product: java
Classification: Unclassified
Component: Compiler
8.2
All All
: P3 (vote)
: 8.2
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-05 06:28 UTC by stefan79
Modified: 2016-07-22 08:33 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (8.63 KB, text/plain)
2016-07-05 06:28 UTC, stefan79
Details
stacktrace (7.75 KB, text/plain)
2016-07-05 17:42 UTC, stefan79
Details
stacktrace (8.08 KB, text/plain)
2016-07-06 12:54 UTC, Tomas Stupka
Details
stacktrace (9.61 KB, text/plain)
2016-07-08 22:36 UTC, nleck
Details
stacktrace (9.61 KB, text/plain)
2016-07-08 22:39 UTC, nleck
Details
stacktrace (9.61 KB, text/plain)
2016-07-08 22:42 UTC, nleck
Details
stacktrace (6.83 KB, text/plain)
2016-07-15 15:48 UTC, Vladimir Voskresensky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefan79 2016-07-05 06:28:02 UTC
Build: NetBeans IDE Dev (Build 201607040002)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.92-b14, Java(TM) SE Runtime Environment, 1.8.0_92-b14
OS: Windows 8.1

User Comments:
stefan79: Exception occured while debugging.

stefan79: Exception occured while debugging in a java-file.




Stacktrace: 
java.lang.AssertionError: isSubtype METHOD
   at com.sun.tools.javac.code.Types$4.visitType(Types.java:1031)
   at com.sun.tools.javac.code.Types$4.visitType(Types.java:1007)
   at com.sun.tools.javac.code.Types$DefaultTypeVisitor.visitMethodType(Types.java:4703)
   at com.sun.tools.javac.code.Type$MethodType.accept(Type.java:1459)
   at com.sun.tools.javac.code.Types$DefaultTypeVisitor.visit(Types.java:4699)
   at com.sun.tools.javac.code.Types.isSubtype(Types.java:1003)
Comment 1 stefan79 2016-07-05 06:28:03 UTC
Created attachment 160256 [details]
stacktrace
Comment 2 stefan79 2016-07-05 17:42:45 UTC
Created attachment 160274 [details]
stacktrace

...
Comment 3 Tomas Stupka 2016-07-06 12:54:47 UTC
Created attachment 160286 [details]
stacktrace

appears from time to time when doing something in the editor ...
Comment 4 nleck 2016-07-08 22:36:47 UTC
Created attachment 160325 [details]
stacktrace

naviate to source
Comment 5 nleck 2016-07-08 22:39:48 UTC
Created attachment 160326 [details]
stacktrace

editing code.
Comment 6 nleck 2016-07-08 22:42:47 UTC
Created attachment 160327 [details]
stacktrace

typing
Comment 7 Vladimir Voskresensky 2016-07-15 15:48:56 UTC
Created attachment 160408 [details]
stacktrace

debugging java
Comment 8 Dusan Balek 2016-07-22 08:33:30 UTC
Already fixed in dev build.

*** This bug has been marked as a duplicate of bug 188662 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo