Bug 188662 - AssertionError: isSubtype 12
AssertionError: isSubtype 12
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Compiler
6.x
All All
: P1 with 2 votes (vote)
: Dev
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
: 206068 262677 267241 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 12:47 UTC by Marian Petras
Modified: 2016-07-22 09:06 UTC (History)
20 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.99 KB, text/plain)
2010-07-14 12:48 UTC, Marian Petras
Details
stacktrace (3.27 KB, text/plain)
2011-07-11 15:43 UTC, Jesse Glick
Details
stacktrace (3.27 KB, text/plain)
2011-09-24 06:16 UTC, David Konecny
Details
stacktrace (3.39 KB, text/plain)
2011-12-07 10:03 UTC, J Bachorik
Details
Dump file as requested (28.01 KB, text/plain)
2012-03-22 15:20 UTC, Jesse Glick
Details
stacktrace (7.59 KB, text/plain)
2012-03-22 15:25 UTC, Jesse Glick
Details
Dump file again (30.81 KB, text/plain)
2012-04-12 01:46 UTC, Jesse Glick
Details
Dump file (56.07 KB, application/octet-stream)
2012-07-11 07:42 UTC, Jaroslav Havlin
Details
stacktrace (10.43 KB, text/plain)
2016-06-23 07:18 UTC, Alexander Simon
Details
stacktrace (10.43 KB, text/plain)
2016-06-23 10:12 UTC, Alexander Simon
Details
stacktrace (9.43 KB, text/plain)
2016-06-23 18:00 UTC, Vladimir Voskresensky
Details
stacktrace (8.94 KB, text/plain)
2016-06-27 12:48 UTC, Maksim Khramov
Details
stacktrace (9.29 KB, text/plain)
2016-06-27 13:42 UTC, Jiri Skrivanek
Details
stacktrace (6.64 KB, text/plain)
2016-06-27 13:45 UTC, Jiri Skrivanek
Details
stacktrace (6.31 KB, text/plain)
2016-06-30 20:48 UTC, alied
Details
stacktrace (7.57 KB, text/plain)
2016-07-03 10:45 UTC, bolsover
Details
stacktrace (6.00 KB, text/plain)
2016-07-05 05:39 UTC, stefan79
Details
stacktrace (8.94 KB, text/plain)
2016-07-05 06:30 UTC, stefan79
Details
stacktrace (8.94 KB, text/plain)
2016-07-05 06:33 UTC, stefan79
Details
stacktrace (6.56 KB, text/plain)
2016-07-08 11:51 UTC, IrianR
Details
stacktrace (6.30 KB, text/plain)
2016-07-11 08:30 UTC, markiewb
Details
stacktrace (9.49 KB, text/plain)
2016-07-12 20:42 UTC, Andrew Krasny
Details
stacktrace (7.35 KB, text/plain)
2016-07-14 18:33 UTC, IrianR
Details
stacktrace (16.18 KB, text/plain)
2016-07-15 15:06 UTC, MackSix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Petras 2010-07-14 12:47:59 UTC
This bug was originally marked as duplicate of bug 163995, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 6.9 (Build 201006101454)
VM: Java HotSpot(TM) Server VM, 17.0-b16, Java(TM) SE Runtime Environment, 1.6.0_21-b06
OS: Windows XP

User Comments:
mpetras: Trying to use code completion for name of an exception in the "throws" declaration of a method. On the first attempt, I get the exception (error), the second time it always works.




Stacktrace: 
java.lang.AssertionError: isSubtype 12
   at com.sun.tools.javac.code.Types$5.visitType(Types.java:384)
   at com.sun.tools.javac.code.Types$5.visitType(Types.java:365)
   at com.sun.tools.javac.code.Types$DefaultTypeVisitor.visitMethodType(Types.java:3428)
   at com.sun.tools.javac.code.Type$MethodType.accept(Type.java:807)
   at com.sun.tools.javac.code.Types$DefaultTypeVisitor.visit(Types.java:3424)
   at com.sun.tools.javac.code.Types.isSubtype(Types.java:361)
Comment 1 Marian Petras 2010-07-14 12:48:04 UTC
Created attachment 100828 [details]
stacktrace
Comment 2 Jesse Glick 2011-07-11 15:43:47 UTC
Created attachment 109370 [details]
stacktrace
Comment 3 Quality Engineering 2011-09-10 14:25:58 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/8205d68aead0
User: Dusan Balek <dbalek@netbeans.org>
Log: Modified to prevent 'AssertionError: isSubtype 12' - see issue #188662.
Comment 4 Exceptions Reporter 2011-09-19 13:23:51 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=171366
Comment 5 David Konecny 2011-09-24 06:16:25 UTC
Created attachment 111130 [details]
stacktrace
Comment 6 J Bachorik 2011-12-07 10:03:59 UTC
Created attachment 113911 [details]
stacktrace

keeps on popping up
Comment 7 Jesse Glick 2012-03-22 15:20:34 UTC
Created attachment 117092 [details]
Dump file as requested

Just opened ShowFailures.java and moved caret around a bit; did not make any edits.
Comment 8 Jesse Glick 2012-03-22 15:25:15 UTC
Created attachment 117094 [details]
stacktrace
Comment 9 Dusan Balek 2012-04-05 12:26:20 UTC
*** Bug 206068 has been marked as a duplicate of this bug. ***
Comment 10 Jesse Glick 2012-04-12 01:46:36 UTC
Created attachment 118168 [details]
Dump file again
Comment 11 Jaroslav Havlin 2012-07-11 07:42:22 UTC
Created attachment 121918 [details]
Dump file
Comment 12 Alexander Simon 2016-06-23 07:18:27 UTC
Created attachment 160141 [details]
stacktrace

goto line from analyze stack window
Comment 13 Alexander Simon 2016-06-23 10:12:27 UTC
Created attachment 160145 [details]
stacktrace

debug allpication
Comment 14 Vladimir Voskresensky 2016-06-23 18:00:27 UTC
Created attachment 160150 [details]
stacktrace

don't remember, but probably
change import from package.OuterClass.Nested to package.OuterClass.*
Comment 15 Maksim Khramov 2016-06-27 12:48:28 UTC
Created attachment 160172 [details]
stacktrace

Edit java code. Replacing direct field access with access through getter
Comment 16 Jiri Skrivanek 2016-06-27 13:42:29 UTC
Created attachment 160173 [details]
stacktrace

While debugging maven java project.
Comment 17 Jiri Skrivanek 2016-06-27 13:45:28 UTC
Created attachment 160174 [details]
stacktrace

While debugging maven java project.
Comment 18 alied 2016-06-30 20:48:32 UTC
Created attachment 160208 [details]
stacktrace

Editing a JUnit test Java file
Comment 19 bolsover 2016-07-03 10:45:35 UTC
Created attachment 160240 [details]
stacktrace

Browsing code in SwingInterop example
Comment 20 stefan79 2016-07-05 05:39:46 UTC
Created attachment 160255 [details]
stacktrace

Exception occured after paste some String?s to java-class.
Comment 21 stefan79 2016-07-05 06:30:45 UTC
Created attachment 160257 [details]
stacktrace

Exception occured while debugging in a java-file.
Comment 22 stefan79 2016-07-05 06:33:45 UTC
Created attachment 160258 [details]
stacktrace

Exception occured while debugging in a java-file.
Comment 23 bolsover 2016-07-05 12:05:41 UTC
Product Version: NetBeans IDE Dev (Build 201606300002)
Java: 1.8.0_92; Java HotSpot(TM) 64-Bit Server VM 25.92-b14
Runtime: Java(TM) SE Runtime Environment 1.8.0_92-b14
System: Windows 10 version 10.0 running on amd64; Cp1252; en_GB (nb)

It looks like this bug is being seen more frequently; I've already seen multiple times using 8.2 development version. The bug appears to be in the compiler but seems to be exposed when using 8.2 development version. 

Error I see now is: 

java.lang.AssertionError: isSubtype METHOD
   at com.sun.tools.javac.code.Types$4.visitType(Types.java:1031)
   at com.sun.tools.javac.code.Types$4.visitType(Types.java:1007)
   at com.sun.tools.javac.code.Types$DefaultTypeVisitor.visitMethodType(Types.java:4703)
   at com.sun.tools.javac.code.Type$MethodType.accept(Type.java:1459)
   at com.sun.tools.javac.code.Types$DefaultTypeVisitor.visit(Types.java:4699)
   at com.sun.tools.javac.code.Types.isSubtype(Types.java:1003)
   at com.sun.tools.javac.code.Types.isSubtype(Types.java:974)
   at com.sun.tools.javac.code.Types.isSubtypeUncheckedInternal(Types.java:929)
   at com.sun.tools.javac.code.Types.isSubtypeUnchecked(Types.java:915)
   at com.sun.tools.javac.comp.Resolve$MethodCheckContext.compatible(Resolve.java:980)
   at com.sun.tools.javac.comp.Check.checkType(Check.java:571)
Comment 24 bolsover 2016-07-05 14:03:16 UTC
Product Version: NetBeans IDE Dev (Build 201606300002)
Java: 1.8.0_92; Java HotSpot(TM) 64-Bit Server VM 25.92-b14
Runtime: Java(TM) SE Runtime Environment 1.8.0_92-b14
System: Windows 10 version 10.0 running on amd64; Cp1252; en_GB (nb)

Exception is thrown when opening file SwingInterop from the Netbeans SwingInterop examples.

Reproducible.
Comment 25 IrianR 2016-07-08 11:51:47 UTC
Created attachment 160317 [details]
stacktrace

Debugging a maven project.
Comment 26 Exceptions Reporter 2016-07-08 11:51:57 UTC
This bug already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=171366
Comment 27 markiewb 2016-07-11 08:30:50 UTC
Created attachment 160344 [details]
stacktrace

????
Comment 28 Andrew Krasny 2016-07-12 20:42:52 UTC
Created attachment 160360 [details]
stacktrace

attempt to step into a method when debugging a test
Comment 29 IrianR 2016-07-14 18:33:54 UTC
Created attachment 160392 [details]
stacktrace

Remote debugging a maven project.
Comment 30 MackSix 2016-07-15 15:06:56 UTC
Created attachment 160407 [details]
stacktrace

Ran I&T ALL Analyzers on Apache Commons Collection 4.0
Comment 32 Quality Engineering 2016-07-21 01:51:24 UTC
Integrated into 'main-silver', will be available in build *201607210002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/94e4745c47c9
User: Dusan Balek <dbalek@netbeans.org>
Log: Issues #188662 and ##262592 - fixed.
Comment 33 Dusan Balek 2016-07-22 08:33:31 UTC
*** Bug 262677 has been marked as a duplicate of this bug. ***
Comment 34 Dusan Balek 2016-07-22 09:06:19 UTC
*** Bug 267241 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo