Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 262315 - Save does not affect jshell if started from NB terminal
Save does not affect jshell if started from NB terminal
Status: RESOLVED INVALID
Product: ide
Classification: Unclassified
Component: Code
8.1
PC Linux
: P3 (vote)
: TBD
Assigned To: issues@ide
issues@ide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-02 20:56 UTC by muellermi
Modified: 2016-06-05 21:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (63.82 KB, text/plain)
2016-06-02 20:56 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2016-06-02 20:56:29 UTC
Product Version = NetBeans IDE Dev (Build 201606020002)
Operating System = Linux version 4.4.0-22-generic running on amd64
Java; VM; Vendor = 1.8.0_91
Runtime = Java HotSpot(TM) 64-Bit Server VM 25.91-b14

Reproducibility: Happens every time

STEPS:
1* download JDK 9 (actual: build 120)
2* launch jshell
3* /set editor netbeans-dev-201606020002/bin/netbeans
4* enter Java stetement
5* /edit
--> Netbeans will be started if not yet running, Java statements of jshell session will be displayed
6* modify or add statement(s)
7* press ctrl+S to save
--> jshell uses the modified commands
8* open terminal window (window, ide tools, terminal)
9* perform steps 2* to 7* using the terminal window
--> jshell ignores the modified data
Comment 1 muellermi 2016-06-02 20:56:35 UTC
Created attachment 159948 [details]
IDE log
Comment 2 muellermi 2016-06-02 20:57:33 UTC
in 
3* /set editor netbeans-dev-201606020002/bin/netbeans
replace the path with the appropriate path to you nb folder
Comment 3 muellermi 2016-06-05 21:57:48 UTC
This seems to be a jshell issue.
The same problem appears if I use a different editor like gedit:
If spawned from jshell, it is ok. If already running, all changes of the snippet will be ignored by jshell.
Thus, I'm going to close this issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo