Bug 258945 - ClassNotFoundException: javax.activation.DataContentHandlerFactory
ClassNotFoundException: javax.activation.DataContentHandlerFactory
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
8.2
All All
: P2 (vote)
: Dev
Assigned To: Tomas Zezula
issues@platform
EXCEPTIONS_REPORT
: JDK_9
: 262501 262528 262636 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-04-21 11:57 UTC by Jiri Prox
Modified: 2017-02-15 14:29 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.26 KB, text/plain)
2016-04-21 11:57 UTC, Jiri Prox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2016-04-21 11:57:16 UTC
Build: NetBeans IDE Dev (Build 201604200001)
VM: Java HotSpot(TM) 64-Bit Server VM, 9-ea+114-2016-04-19-165051.javare.4880.nc, Java(TM) SE Runtime Environment, 9-ea+114-2016-04-19-165051.javare.4880.nc
OS: Mac OS X

User Comments:
jiriprox: Starting Netbeans on JDK9jigsaw




Stacktrace: 
java.lang.ClassNotFoundException: javax.activation.DataContentHandlerFactory
   at jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:366)
   at jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:184)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:419)
   at org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:222)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:419)
   at org.openide.awt.QuickSearch.setUpSearch(QuickSearch.java:369)
Comment 1 Jiri Prox 2016-04-21 11:57:17 UTC
Created attachment 159369 [details]
stacktrace
Comment 2 Jiri Prox 2016-04-21 12:42:51 UTC
This issues blocks using Netbeans.
Comment 3 Ralph Ruijs 2016-06-27 08:46:21 UTC
*** Bug 262528 has been marked as a duplicate of this bug. ***
Comment 4 Ralph Ruijs 2016-06-27 08:46:36 UTC
*** Bug 262501 has been marked as a duplicate of this bug. ***
Comment 5 Ralph Ruijs 2016-06-27 08:48:40 UTC
Maybe cause by http://openjdk.java.net/jeps/261#Root-modules ?
Comment 6 Ralph Ruijs 2016-06-28 07:41:22 UTC
Adding "-addmods ALL-DEFAULT,java.se.ee" to $jargs in nbexec solves the problem for me.

It is sensitive to the order as I need the fix from #258952 as well.
Comment 7 Tomas Zezula 2016-06-29 05:30:49 UTC
Thanks Ralph.
The java.se.ee is not activated automatically now. The java.se is which does not depend in java.ee.

The launchers will need to change anyway as the  addmods, addExports will no more be java launcher options but JVM options handled by JNI_CreateJavaVM. Currently the addexports are passed as -D to JVM. The lauchers will need to detect JVM they are starting and if JDK 9 add the add... to cmd line.
Comment 8 Ralph Ruijs 2016-07-04 08:33:56 UTC
*** Bug 262636 has been marked as a duplicate of this bug. ***
Comment 9 Tomas Hurka 2017-02-15 14:29:03 UTC
Already fixed in trunk.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo