Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 25868 - Provide autoload modules for different versions of XML parsers
Provide autoload modules for different versions of XML parsers
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: libs
3.x
All All
: P3 (vote)
: 3.x
Assigned To: issues@ide
issues@ide
http://xml.apache.org/xerces2-j/
:
: 26642 (view as bug list)
Depends on:
Blocks: 17815 20269
  Show dependency treegraph
 
Reported: 2002-07-22 12:48 UTC by David Konecny
Modified: 2003-12-11 14:24 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Konecny 2002-07-22 12:48:17 UTC
In issue 20269 we have agreed (with Petr K.) that XML module should provide autoload 
NetBeans modules containing different versions of XML parsers (eg. xerces_version_2_0). 
Other modules written for some concrete parser version will then be able to specify module 
dependency on this module.
Comment 1 _ lkramolis 2002-08-06 17:09:43 UTC
I will create a "org.netbeans.libs.xerces20x" module that will cover
Apache's Xerces 2.0.x library (see discussion in issue 20269).

Q: Do you agree with name (xerces20x) what should describe any minor
release of Xerces 2.0.
Comment 2 _ pkuzel 2002-08-06 17:21:37 UTC
Unfortunatelly there are major behaviour changes for Xerces minor
releases (e.g. 2.0.1 vs 2.0.2 in XML Schema area).

What about explicit module names like org.netbeans.libs.xerces.vX_X_X
?
Comment 3 _ lkramolis 2002-08-07 09:06:06 UTC
I am not sure if it was intention to make such changes in minor
release. But maybe it is safe to depend on concrete release.

David, do you still want to depend on any 2.0.x or depend exactly on
2.0.2 (I think ...xerces202 is better name)? Or maybe I could wait for
2.0.3 that could fix mentioned bug (but probably bring new bugs).

I will cover version you will ask for. :-) Please, could you confirm
your request? Thanks.
Comment 4 David Konecny 2002-08-07 16:05:09 UTC
The version which I would expect to get is the one used in NB3.4 - I
don't know exactly the version number, but Ant is tested with it and
works fine. If a major new version appear during the next NB version
release or if some serious bug would be discovered in the currently
used one, I would consider upgrade to a newer version. But for the
moment existing one seems OK to me.
Comment 5 _ lkramolis 2002-08-22 17:38:43 UTC
New Xerces module have been introduced.

For more information see http://libs.netbeans.org/#xerces.
Comment 6 _ lkramolis 2002-08-22 17:41:00 UTC
*** Issue 26642 has been marked as a duplicate of this issue. ***
Comment 7 David Konecny 2002-08-23 09:56:17 UTC
Thank you. I will try to use in Ant soon.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo