Bug 254649 - com.sun.tools.javac.comp.Check.checkType: LowPerformance took 35628 ms.
com.sun.tools.javac.comp.Check.checkType: LowPerformance took 35628 ms.
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Compiler
8.0
All All
: P3 (vote)
: 8.1
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 252182 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-24 11:14 UTC by Exceptions Reporter
Modified: 2015-09-25 11:04 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (1002.45 KB, application/nps)
2015-08-24 11:15 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2015-08-24 11:14:49 UTC
This issue was reported manually by cezariusz.
It already has 8 duplicates 


Build: NetBeans IDE 8.0.2 (Build 201411181905)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.25-b02, Java(TM) SE Runtime Environment, 1.8.0_25-b18
OS: Windows 8

User Comments:
GUEST: autocomplete is very very slow

abien: happened during auto completion

abien: Happened during autocompletion. Looked like GC issue

everflux: code completion inside java 8 stream/filter

cezariusz: Code completion, right after moving the class to a different module.

GUEST: IDE blocked 1min to download javadoc without being requested!

cezariusz: Code completion, right after moving the class to a different module.

everflux: code completion was slow, UI was completely blocked



Maximum slowness yet reported was 49062 ms, average is 18249
Comment 1 Exceptions Reporter 2015-08-24 11:15:04 UTC
Created attachment 155577 [details]
nps snapshot
Comment 2 Dusan Balek 2015-09-08 11:48:22 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/418349e00f0e
Comment 3 Quality Engineering 2015-09-09 01:23:00 UTC
Integrated into 'main-silver', will be available in build *201509090002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/418349e00f0e
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #254649 - com.sun.tools.javac.comp.Check.checkType: LowPerformance - fixed.
Comment 4 Dusan Balek 2015-09-25 11:04:54 UTC
*** Bug 252182 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo