Bug 254510 - com.sun.tools.javac.jvm.ClassReader.fillIn: LowPerformance took 5877 ms.
com.sun.tools.javac.jvm.ClassReader.fillIn: LowPerformance took 5877 ms.
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
8.1
All All
: P3 (vote)
: 8.1
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 12:58 UTC by lolo_101
Modified: 2015-09-24 14:26 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (72.09 KB, application/nps)
2015-08-19 12:58 UTC, lolo_101
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lolo_101 2015-08-19 12:58:46 UTC
This bug was originally marked as duplicate of bug 251825, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 8.1 Beta (Build 201508041349)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.51-b03, Java(TM) SE Runtime Environment, 1.8.0_51-b16
OS: Windows 7

User Comments:
Lolo_101: Normal java code edition... 39 open maven projects.



Maximum slowness yet reported was 5877 ms, average is 5877
Comment 1 lolo_101 2015-08-19 12:58:49 UTC
Created attachment 155452 [details]
nps snapshot
Comment 2 Dusan Balek 2015-09-24 14:26:28 UTC
As can be seen from the attach profiler snapshot - all IDE activity seems to be blocked by an extremely slow IO (usually java.io.WinNTFileSystem.list).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo