Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 250869 - Closing Project Group with 280 maven modules takes 2+ minutes
Closing Project Group with 280 maven modules takes 2+ minutes
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
8.1
PC Windows XP
: P3 (vote)
: TBD
Assigned To: Tomas Stupka
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-03 14:13 UTC by NukemBy
Modified: 2015-04-17 11:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
selfsampler-2minutes-to-close-280modules.npss (927.26 KB, application/octet-stream)
2015-03-03 14:13 UTC, NukemBy
Details
closing-304-maven-modules.npss (342.88 KB, application/octet-stream)
2015-04-17 11:56 UTC, NukemBy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NukemBy 2015-03-03 14:13:02 UTC
Created attachment 152367 [details]
selfsampler-2minutes-to-close-280modules.npss

Steps to reproduce:

1. Create new Project Group

2. Open in that project group the test project from here (https://netbeans.org/bugzilla/show_bug.cgi?id=250833)

3. Wait until all background processes are completed

4. Switch to '(none)' project groups - this operation takes 2 minutes for me.

Self profiler snapshot is attached.
Comment 1 Tomas Stupka 2015-04-14 15:21:02 UTC
implicit BaseFileObj.toString() 
in
thread.setName(threadName + " :: " + operation + " " + fe.getFile())
in
FCLSupport.dispatchEventImpl() 
takes up most of the time

seems like calling BaseFileObj.getPath() at that place would be enough
and it is a lot cheaper that BaseFileObj.toString() (which was added because of diagnostic reasons anyway)

will fix accordingly, hopefully it will solve the problem

Jarda H, please let me know if you have a problem with the change
Comment 2 Tomas Stupka 2015-04-14 15:28:32 UTC
fixed in jet-main #cfce69a9f825
Comment 3 Jaroslav Havlin 2015-04-15 07:18:38 UTC
 > Jarda H, please let me know if you have a problem with the change
No problem.

> fixed in jet-main #cfce69a9f825
Thank you, Tomas.
Comment 4 Quality Engineering 2015-04-16 06:36:42 UTC
Integrated into 'main-silver', will be available in build *201504160452* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/cfce69a9f825
User: Tomas Stupka <tstupka@netbeans.org>
Log: Issue #250869 - Closing Project Group with 280 maven modules takes 2+ minutes
Comment 5 NukemBy 2015-04-17 11:55:28 UTC
Checked this issue in my environment - now NB becomes responsive in around 15 seconds. This is much better than 2 minutes, but probably there still some space for improvement.

Attaching current NPSS just in case someone would like to dig that dipper:
- 8:32:11 -> 8:32:14 - [3 seconds] to show up contextual menu
  There is separate bug for that: 
    https://netbeans.org/bugzilla/show_bug.cgi?id=250872

- 8:32:25 -> 8:32:40 - [7-10 seconds] to close projects + around [5-7 seconds] runs some weird background scan on absolutely empty workspace.
Comment 6 NukemBy 2015-04-17 11:56:09 UTC
Created attachment 153251 [details]
closing-304-maven-modules.npss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo