Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 24964 - Implement some support for Hyperlinks
Implement some support for Hyperlinks
Status: CLOSED WONTFIX
Product: debugger
Classification: Unclassified
Component: Code
3.x
All All
: P2 (vote)
: 6.x
Assigned To: issues@debugger
issues@debugger
:
: 11821 (view as bug list)
Depends on: 31896
Blocks: 24758
  Show dependency treegraph
 
Reported: 2002-06-19 16:56 UTC by Jan Jancura
Modified: 2010-04-29 09:10 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Jancura 2002-06-19 16:56:13 UTC
Currently we have some implementation of Hyperlink
property editor in debugger. But current support
for PropertyEditors in OpenIDE is little bit
restrictive, so we can not make a really good
impl. The main problem is that we can not redefine
"read" state of PE (something like
InLinePropertyViewer...)
Comment 1 Marek Grummich 2002-07-22 11:18:00 UTC
Set target milestone to TBD
Comment 2 Marek Grummich 2002-07-22 11:20:58 UTC
Set target milestone to TBD
Comment 3 David Strupl 2002-07-29 16:36:22 UTC
*** Issue 11821 has been marked as a duplicate of this issue. ***
Comment 4 Jiri Rechtacek 2003-03-24 15:15:11 UTC
reassigning to Tim as property editor's owner
Comment 5 _ tboudreau 2003-03-25 16:35:43 UTC
Please clarify what you need to do here.  I do not entirely understand
the "When the keyboard focus is on a cell with a hyperlink" text in
issue 24758.  What cell in what component?

Is the issue that the editor component is not constructed until focus 
is set to it, or something else?  Is it a use case of PropertySheet
or PropertyPanel?

I think this will be more possible with the propertysheet rewrite
(editors will be able to receive and respond to the key/mouse event
that instantiated them if they need to), but I'm still not sure what
you're trying to do.
Comment 6 _ tboudreau 2003-04-14 12:40:57 UTC
The best way to implement this would be to add a hook method to the
InplaceEditor interface in the propertysheet rewrite, or a hint that
clicking on a property in the values column should call some method,
rather than instantiate the inline editor component.  If this is
really needed, you should let me know soon, as InplaceEditor will
become API in a few weeks.

However, I still don't understand the use case.  It seems like you 
want to be able to open a browser from a hyperlink in a property
value?  What are you trying to do?  I'm tempted to close this issue
as wontfix, since it seems way out of scope for a property sheet.
Let me know, soon, why such functionality would be useful.

Or do you just want a better custom editor for URLs?  If so, this
sounds like a duplicate of issue 6024.  Let me know.
Comment 7 Jan Jancura 2003-04-15 08:31:56 UTC
What I need is the Hyperlink property editor look exactly as in
Internet Exporer: blue underlined text, different mouse icon, and when
you click on it the color is changed to red.
When you click on it some method should be called. I am not able to
implement it correctly using current support - see debugger window
Watches view - type of some variable.
Comment 8 _ tboudreau 2003-04-25 10:27:09 UTC
Wow, that's pretty weird.

I don't think such a property editor belongs in core
or openide.  I assume you're using PropertyPanel, not
PropertySheet.  Opening a browser when someone clicks a
property in the property sheet would be weird and 
unexpected.

Once the new property sheet is integrated, and I finish
rewriting PropertyPanel to use its rendering/editing
infrastructure, you will be able to do the following,
which will solve the problem:

 - Create a custom hyperlink ExPropertyEditor
 - Create a custom Inplace editor implementing the 
   InplaceEditor interface
 - Have your property editor call the new 
   registerInplaceEditor method on the PropertyEnv
   in attachEnv().
 - Return isPaintable=true, and paint an instance
   of the inplace editor from the property editor's
   paint() method
 - Let your inplace editor respond to mouse clicks however
   you want.  Override 
   InplaceEditor.handleInitialInputEvent() to get the 
   mouse click event that instantiated the editor, and
   process it by opening the URL.

I'm reassigning this to debugger - as far as I can tell,
there are no use cases of this functionality outside the
debugger module, and it would do more harm than good in
core.
Comment 9 Martin Entlicher 2005-12-12 14:37:47 UTC
WONTFIX - the hyperlinks are not needed IMHO.
Comment 10 Quality Engineering 2010-04-29 09:10:46 UTC
Verified ... and Closing all issues resolved into NetBeans 6.7 and earlier.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo