Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 11821 - Option to make custom property editor components persist when property editor field does not have focus
Option to make custom property editor components persist when property editor...
Status: CLOSED DUPLICATE of bug 24964
Product: platform
Classification: Unclassified
Component: Property Editors
3.x
PC Linux
: P4 (vote)
: TBD
Assigned To: akemr
issues@platform
: API, UI
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 19:39 UTC by _ tboudreau
Modified: 2008-12-22 21:47 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2001-04-27 19:39:17 UTC
I have a custom property editor component I would like to integrate with the 
IDE. This can be done with EnhancedPropertyEditor.  There is one problem:

My component needs to perform an action (pop up a palette) the first time it is 
clicked.  But my custom property editor is not actually instantiated until the 
property editor field receives focus.  So it always requires two clicks.

What I'd propose is an enhancement to the api for EnhancedPropertyEditor - 
perhaps a "persistent" property that, when true, means that the property editor 
will be instantiated for the life of the property sheet.
Comment 1 Jan Chalupa 2001-05-05 20:33:30 UTC
Target milestone -> 3.3
Comment 2 Jan Chalupa 2001-11-27 11:52:52 UTC
Target milestone -> 3.3.1.
Comment 3 Jan Chalupa 2001-11-27 11:56:29 UTC
Target milestone -> 3.3.1.
Comment 4 Jan Chalupa 2002-01-11 14:03:16 UTC
Target milestone -> 3.4
Comment 5 Jan Chalupa 2002-01-11 14:07:19 UTC
Target milestone -> 3.4
Comment 6 Jan Chalupa 2002-01-11 14:08:29 UTC
Target milestone -> 3.4
Comment 7 Jan Chalupa 2002-01-11 14:11:20 UTC
Target milestone -> 3.4
Comment 8 akemr 2002-02-11 12:46:02 UTC
Decreased priority - planning resources for 3.4
Comment 9 Marek Grummich 2002-07-22 08:34:05 UTC
Target milestone was changed from '3.4' to TBD.
Comment 10 Marek Grummich 2002-07-22 08:47:20 UTC
Target milestone was changed from '3.4' to TBD.
Comment 11 David Strupl 2002-07-29 16:36:24 UTC
The solution to #24964 would also solve this request (as I hope). It
would allow you to specify a component for so called "read" state of
the property panel (in properyt sheet).

Making it duplicate of the mentioned issue. If you disagree that those
issues are in fact the same please reopen this one. Otherwise if you
are interested in progress please watch the other one.

*** This issue has been marked as a duplicate of 24964 ***
Comment 12 _ tboudreau 2002-07-29 17:48:47 UTC
Uh, maybe...I'm not sure how hyperlinks relates to this, since I 
don't imagine a hyperlink to be a property editor.  But I'll take
your word for it.

BTW, if you look at the patch I submitted for the Options UI,
it includes an extension to PropertyEditor - getPersistentEditor() 
which could solve the problem.
Comment 13 Jiri Rechtacek 2002-07-30 13:52:07 UTC
Tim, could you add a link at the patch for Options UI submitted by
you? Thanks
Comment 14 Marian Mirilovic 2003-07-18 13:27:17 UTC
verified, closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo