Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 241685 - Issue while creating demo project
Issue while creating demo project
Status: RESOLVED DUPLICATE of bug 240180
Product: projects
Classification: Unclassified
Component: Maven
8.0
Macintosh (x86) Mac OS X
: P3 (vote)
: 8.0
Assigned To: Milos Kleint
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-11 10:45 UTC by michal.owsiak
Modified: 2014-02-13 14:24 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michal.owsiak 2014-02-11 10:45:54 UTC
To reproduce:

1. Install C/C++ plugin
2. Create sample C/C++ project "Welcome"
3. Right-click on "Welcome_1"

NetBeans raises exception:

java.lang.AssertionError: Need to normalize /Users/michalo/NetBeansProjects/welcome_1(class java.io.File) was /Users/michalo/NetBeansProjects/Welcome_1(class java.io.File)
Comment 1 ilia 2014-02-12 06:33:58 UTC
Is this issue reproducible on your computer? I can't reproduce it.
If so, attach a full stack trace, or send an exception report.

Thanks!
Comment 2 Alexander Simon 2014-02-12 06:49:00 UTC
(In reply to ilia from comment #1)
> Is this issue reproducible on your computer? I can't reproduce it.
> If so, attach a full stack trace, or send an exception report.
> 
> Thanks!
Ilia,

It is a mac specific issue (file system by default case insensitive).
Did you try reproduce the bug on a mac?
Comment 3 michal.owsiak 2014-02-12 06:55:08 UTC
Hello,

to reproduce the issue, you have to create project "Welcome" on OS X.

Note that OS X case sensitivity is not the same as on Linux!

You can have two files with different case sensitivity, but you can't have them at the same time in the same directory!

Take a look here:
https://discussions.apple.com/message/21905948#21905948


java.lang.AssertionError: Need to normalize /Users/michalo/NetBeansProjects/welcome_1(class java.io.File) was /Users/michalo/NetBeansProjects/Welcome_1(class java.io.File)
	at org.openide.filesystems.FileUtil.assertNormalized(FileUtil.java:153)
	at org.openide.filesystems.FileUtil.toFile(FileUtil.java:829)
	at org.netbeans.modules.maven.queries.MavenFileOwnerQueryImpl.getOwner(MavenFileOwnerQueryImpl.java:238)
	at org.netbeans.api.project.FileOwnerQuery.getOwner(FileOwnerQuery.java:102)
	at org.netbeans.modules.css.indexing.CssIndexer.fireChangeImpl(CssIndexer.java:205)
	at org.netbeans.modules.css.indexing.CssIndexer.access$000(CssIndexer.java:77)
	at org.netbeans.modules.css.indexing.CssIndexer$1.run(CssIndexer.java:199)
Caused: org.openide.util.RequestProcessor$SlowItem: task failed due to
	at org.openide.util.RequestProcessor.post(RequestProcessor.java:419)
	at org.netbeans.modules.css.indexing.CssIndexer.fireChange(CssIndexer.java:196)
	at org.netbeans.modules.css.indexing.CssIndexer.access$300(CssIndexer.java:77)
	at org.netbeans.modules.css.indexing.CssIndexer$Factory.scanFinished(CssIndexer.java:246)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.scanFinished(RepositoryUpdater.java:2427)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$AbstractRootsWork.scanSource(RepositoryUpdater.java:5356)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$AbstractRootsWork.scanSources(RepositoryUpdater.java:5045)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$RootsWork.getDone(RepositoryUpdater.java:4703)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:3253)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task._run(RepositoryUpdater.java:5779)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.access$5300(RepositoryUpdater.java:5445)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$3$1.run(RepositoryUpdater.java:5704)
	at org.netbeans.modules.parsing.impl.RunWhenScanFinishedSupport.performScan(RunWhenScanFinishedSupport.java:96)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$3.call(RepositoryUpdater.java:5700)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$3.call(RepositoryUpdater.java:5696)
	at org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO(FileChangedManager.java:176)
	at org.netbeans.modules.masterfs.providers.ProvidedExtensions.priorityIO(ProvidedExtensions.java:360)
	at org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Utilities.java:74)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.run(RepositoryUpdater.java:5696)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1423)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2033)
Comment 4 ilia 2014-02-13 08:26:03 UTC
A cause of this bug, apparently, is MavenFileOwnerQueryImpl. Reassigning to projects/maven.
Comment 5 Milos Kleint 2014-02-13 14:24:25 UTC
(In reply to ilia from comment #4)
> A cause of this bug, apparently, is MavenFileOwnerQueryImpl. Reassigning to
> projects/maven.

No, it's not. taking a FileObject and attempting to convert it to File via FileUtil.toFile(FileObject) is fairly legal thing to do, if it fails, it has to do with implementation of FileObject on mac platform.

duplicate of issue 240180 as far as I can see

*** This bug has been marked as a duplicate of bug 240180 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo