Bug 240901 - org.openide.nodes.Node.getLookup: LowPerformance took 29019 ms.
org.openide.nodes.Node.getLookup: LowPerformance took 29019 ms.
Status: RESOLVED DUPLICATE of bug 235748
Product: platform
Classification: Unclassified
Component: Lookup
7.4
All All
: P3 (vote)
: 8.0
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-23 18:37 UTC by yogi_varma
Modified: 2014-02-14 11:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (12.10 KB, application/nps)
2014-01-23 18:37 UTC, yogi_varma
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yogi_varma 2014-01-23 18:37:15 UTC
Build: NetBeans IDE 7.4 (Build 201310111528)
VM: Java HotSpot(TM) Client VM, 24.45-b08, Java(TM) SE Runtime Environment, 1.7.0_45-b18
OS: Windows 7

User Comments:
yogi_varma: tooslow

javydreamercsw: Switched focus from another application. (Ctrl+tab)



Maximum slowness yet reported was 29019 ms, average is 11514
Comment 1 yogi_varma 2014-01-23 18:37:17 UTC
Created attachment 144317 [details]
nps snapshot
Comment 2 Ondrej Vrabec 2014-02-13 10:25:42 UTC
look like another duplicates of lookup firing events before the lookup items are all collected and prepared.
Comment 3 Jaroslav Tulach 2014-02-14 11:21:45 UTC

*** This bug has been marked as a duplicate of bug 235748 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo