Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 240632 - IllegalArgumentException: Parameter must be a valid folder.
IllegalArgumentException: Parameter must be a valid folder.
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
7.4
All All
: P3 (vote)
: TBD
Assigned To: Milos Kleint
issues@projects
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-17 22:37 UTC by jdlee
Modified: 2014-01-18 12:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.12 KB, text/plain)
2014-01-17 22:37 UTC, jdlee
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jdlee 2014-01-17 22:37:03 UTC
Build: NetBeans IDE 7.4 (Build 201310111528)
VM: Java HotSpot(TM) 64-Bit Server VM, 24.51-b03, Java(TM) SE Runtime Environment, 1.7.0_51-b13
OS: Linux

User Comments:
jdlee: Trying to create a new Gradle-based project




Stacktrace: 
java.lang.IllegalArgumentException: Parameter must be a valid folder.
   at org.netbeans.spi.project.ui.support.ProjectChooser.setProjectsFolder(ProjectChooser.java:76)
   at org.netbeans.gradle.project.newproject.NewProjectUtils.setDefaultProjectDir(NewProjectUtils.java:61)
   at org.netbeans.gradle.project.newproject.GradleSingleProjectPropertiesPanel.getConfig(GradleSingleProjectPropertiesPanel.java:89)
   at org.netbeans.gradle.project.newproject.GradleSingleProjectConfigPanel.storeSettings(GradleSingleProjectConfigPanel.java:48)
   at org.netbeans.gradle.project.newproject.GradleSingleProjectConfigPanel.storeSettings(GradleSingleProjectConfigPanel.java:9)
   at org.openide.WizardDescriptor.callInstantiateOpen(WizardDescriptor.java:1615)
Comment 1 jdlee 2014-01-17 22:37:04 UTC
Created attachment 144092 [details]
stacktrace
Comment 2 Milos Kleint 2014-01-18 09:29:03 UTC
gradle project type related?
Comment 3 attila.kelemen 2014-01-18 12:31:33 UTC
(In reply to Milos Kleint from comment #2)
> gradle project type related?

Yes. Should now be fixed in master. This is most likely caused by deleting the last used "Project Location" folder. For now, the workaround is to adjust "~/NetBeans/7.4/config/Preferences/org/netbeans/gradle/gradle.properties": Remove the "default-project-dir" line.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo