Bug 236066 - Wrong CP entries warnings
Wrong CP entries warnings
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
8.0
PC Linux
: P3 with 1 vote (vote)
: 8.1
Assigned To: Petr Hejl
issues@serverplugins
:
: 233083 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 11:40 UTC by Petr Hejl
Modified: 2015-04-30 02:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Hejl 2013-09-17 11:40:06 UTC
Register GFv4 in dev build.

WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/mq/lib/jaxm-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/endorsed/javax.annotation-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/endorsed/jaxb-api-osgi.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/endorsed/webservices-api-osgi.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/bean-validator.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.batch-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.ejb-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.el.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.enterprise.concurrent-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.enterprise.concurrent.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.enterprise.deploy-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.faces.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.inject.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.interceptor-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.jms-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.json.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.mail.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.management.j2ee-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.persistence.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.resource-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.security.auth.message-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.security.jacc-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.servlet-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.servlet.jsp-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.servlet.jsp.jar in Library: Java-EE-GlassFish-v3-Prelude
INFO [glassfish]: Created GlassFish Server 4 instance with name GlassFish Server
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.servlet.jsp.jstl-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.servlet.jsp.jstl.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.transaction-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.websocket-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.ws.rs-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.xml.registry-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/javax.xml.rpc-api.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/jaxb-osgi.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/webservices-osgi.jar in Library: Java-EE-GlassFish-v3-Prelude
WARNING [org.netbeans.modules.java.j2seplatform.libraries.J2SELibraryTypeProvider]: Wrong Classpath entry file:/home/sickboy/software/glassfish4/glassfish/modules/weld-osgi-bundle.jar in Library: Java-EE-GlassFish-v3-Prelude
Comment 1 TomasKraus 2013-09-17 13:47:26 UTC
*** Bug 233083 has been marked as a duplicate of this bug. ***
Comment 2 TomasKraus 2013-09-17 13:47:50 UTC
Yes, this was already reported in bug# 233083 by Sergey. I'll keep this bug opened to track it.
Comment 3 Petr Hejl 2015-04-29 12:37:25 UTC
Fixed in web-main 2c156ee021af.
Comment 4 Quality Engineering 2015-04-30 02:33:15 UTC
Integrated into 'main-silver', will be available in build *201504300001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/2c156ee021af
User: Petr Hejl <phejl@netbeans.org>
Log: #236066 - Wrong CP entries warnings


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo