Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 235551 - Use Ctrl+Shift+I to resolve namespace declarations
Use Ctrl+Shift+I to resolve namespace declarations
Status: RESOLVED DUPLICATE of bug 205232
Product: javaee
Classification: Unclassified
Component: JSF Editor
7.4
PC Linux
: P3 (vote)
: 8.0
Assigned To: Martin Fousek
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 11:54 UTC by Vladimir Riha
Modified: 2013-09-09 07:01 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2013-09-05 11:54:55 UTC
It could be handy to use the Ctrl+Shift+I shortcut for resolving (add missing, remove unused) namespace declarations in XHTML facelet page. Semantically it is similar action to e.g. adding imports in Java or uses in PHP.
Comment 1 Vladimir Riha 2013-09-05 11:55:33 UTC
But it would probably require also dialog where user can select proper namespaces if there are multiple choices :)
Comment 2 Martin Fousek 2013-09-09 07:01:03 UTC
Thanks Vlado for the report. It's definitelly great idea and I think that users would appreciate that. Actually I found similar issue by creation of plans for NB80, so I'm marking this issue as a duplicate. But I believe that we will be implement this into next version.

*** This bug has been marked as a duplicate of bug 205232 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo