Bug 205232 - Shortcut to import several namespace prefixes
Shortcut to import several namespace prefixes
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: JSF Editor
-S1S-
All All
: P2 (vote)
: 8.0
Assigned To: Martin Fousek
issues@javaee
:
: 235551 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-16 21:55 UTC by arungupta
Modified: 2013-11-08 12:15 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description arungupta 2011-11-16 21:55:38 UTC
In an .xhtml file, there should be a shortcut to fix imports for several pre-defined namespace prefixes such as f and h.
Comment 1 Martin Fousek 2013-09-09 07:01:03 UTC
*** Bug 235551 has been marked as a duplicate of this bug. ***
Comment 2 Martin Fousek 2013-11-06 14:35:28 UTC
Most of this implemented in:
web-main #e47c5a5d983f
web-main #06c675cac3f8
web-main #1e19beb61747
web-main #906366fc63ef
web-main #cea7e9459276
web-main #a59955f98773
web-main #a89df4f09e92
web-main #f30c7e0c432a

It's not fully finished and I'll work more on that but the basic functionality is already pushed into the trunk. Marking as fixed - remaining TODOs I have noticed.
Comment 3 Martin Fousek 2013-11-07 08:39:56 UTC
BTW, the shortcut set to this action is CTRL+SHIFT+I and the action works as a Fix Imports global or Fix Namespaces popup action.
Comment 4 Vladimir Riha 2013-11-08 11:25:39 UTC
I briefly try it and it seems to work quite well. I have one observation (but perhaps it is in your todo list). When I have a custom (non-standard) prefix for namespace, like

<test:choose>

</test:choose>

and select jstl/core ns to be imported, would it make sense to import it with prefix "test" instead of "c"? 

xmlns:test="http://xmlns.jcp.org/jsp/jstl/core"
Comment 5 Martin Fousek 2013-11-08 12:05:03 UTC
You are definitely right, could you enter an issue against it to have it tracked? Thanks a lot.
Comment 6 Vladimir Riha 2013-11-08 12:15:27 UTC
Reported as issue 238155


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo