Bug 230525 - Dependencies node not visible in projects view
Dependencies node not visible in projects view
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.3.1
PC Mac OS X
: P1 (vote)
: 7.3.1
Assigned To: Jiri Rechtacek
issues@projects
73patch2-verified
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-30 12:26 UTC by Tomas Danek
Modified: 2013-05-31 12:27 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2013-05-30 12:26:24 UTC
Product Version: NetBeans IDE 7.3.1 (Build 201305291404)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b13
System: Mac OS X version 10.8.3 running on x86_64; US-ASCII; en_US (nb)
User directory: /Users/tomas/Library/Application Support/NetBeans/7.3.1
Cache directory: /Users/tomas/Library/Caches/NetBeans/7.3.1
-----------------------
- create Maven | Java application
- Dependencies node is not visible unless dependency is added in pom.xml

most likely regression from http://hg.netbeans.org/releases/rev/97c44a5aac61
Comment 1 Jiri Rechtacek 2013-05-30 13:31:54 UTC
http://hg.netbeans.org/releases/rev/160239058fef
Comment 2 Tomas Danek 2013-05-30 14:46:24 UTC
verified in 7.3.1 custom build

Product Version: NetBeans IDE 7.3.1 (Build 20130530-ce962b7ce537)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b13
System: Mac OS X version 10.8.3 running on x86_64; UTF-8; en_US (nb)
User directory: /tmp/731test
Cache directory: /tmp/731test/var/cache

will verify in 7.3 patch2 once catalog is available.
Comment 3 Quality Engineering 2013-05-30 18:17:37 UTC
Integrated into 'releases', will be available in build *201305301707* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/160239058fef
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #230525 - Dependencies node not visible in projects view
Comment 4 Marian Mirilovic 2013-05-31 06:56:55 UTC
Looks like it works in :
Product Version: NetBeans IDE 7.3.1 (Build 201305301707)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b13
System: Linux version 3.5.0-31-generic running on amd64; UTF-8; en_US (nb)

Tomas, please double-check.
Comment 5 Tomas Danek 2013-05-31 12:27:07 UTC
verified in 7.3 + latest patch2 bits from staging.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo