Bug 230206 - NullPointerException at org.netbeans.modules.web.webkit.debugging.api.css.SourceRange.<init>
NullPointerException at org.netbeans.modules.web.webkit.debugging.api.css.Sou...
Status: VERIFIED FIXED
Product: web
Classification: Unclassified
Component: CSS Visual Tools
7.3
All All
: P1 (vote)
: 7.3.1
Assigned To: Jan Stola
Vladimir Riha
EXCEPTIONS_REPORT, 73patch2-verified
:
: 230602 230692 230791 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 21:08 UTC by bobo_of_id
Modified: 2013-06-07 08:49 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.04 KB, text/plain)
2013-05-23 21:08 UTC, bobo_of_id
Details
stacktrace (2.04 KB, text/plain)
2013-05-24 12:03 UTC, marco76
Details
stacktrace (2.04 KB, text/plain)
2013-05-24 12:06 UTC, marco76
Details
stacktrace (2.04 KB, text/plain)
2013-05-24 12:09 UTC, marco76
Details
stacktrace (2.04 KB, text/plain)
2013-05-26 22:04 UTC, Petr Jiricka
Details
stacktrace (2.30 KB, text/plain)
2013-05-26 22:07 UTC, Petr Jiricka
Details
stacktrace (2.54 KB, text/plain)
2013-05-27 11:46 UTC, Vladimir Riha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bobo_of_id 2013-05-23 21:08:30 UTC
Build: NetBeans IDE Dev (Build 201305212300)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_11-b21
OS: Windows 7

User Comments:
GUEST: I'm working with HTML5 and JavaScript. This does not affect my project

hermes85pl: I tried to use NetBeans Connector in Chrome.

GUEST: I have no idea but i receive many several exceptions

GUEST: Error when i try to copy an HTML5 span element

GUEST: i was trying to update my NetBeans, & then i got this error

hermes85pl: I was trying to use NetBeans Connector in Chrome.

bobo_of_id: Ran a HTML5 angular App




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.web.webkit.debugging.api.css.SourceRange.<init>(SourceRange.java:63)
   at org.netbeans.modules.web.webkit.debugging.api.css.Property.<init>(Property.java:93)
   at org.netbeans.modules.web.webkit.debugging.api.css.Style.<init>(Style.java:80)
   at org.netbeans.modules.web.webkit.debugging.api.css.Rule.<init>(Rule.java:103)
   at org.netbeans.modules.web.webkit.debugging.api.css.StyleSheetBody.<init>(StyleSheetBody.java:74)
   at org.netbeans.modules.web.webkit.debugging.api.css.CSS.getStyleSheet(CSS.java:143)
Comment 1 bobo_of_id 2013-05-23 21:08:32 UTC
Created attachment 134836 [details]
stacktrace
Comment 2 marco76 2013-05-24 12:03:54 UTC
Created attachment 134862 [details]
stacktrace

renaming a css file
Comment 3 marco76 2013-05-24 12:06:54 UTC
Created attachment 134863 [details]
stacktrace

update a stylesheet reference in an html file
Comment 4 marco76 2013-05-24 12:09:54 UTC
Created attachment 134865 [details]
stacktrace

saved the file with ctrl+s
Comment 5 Petr Jiricka 2013-05-26 22:04:14 UTC
Created attachment 134923 [details]
stacktrace

I believe what I did was:
1. Run HTML5 application in Chrome with NB integration
2. Close the Chrome tab
3. Shut down Chrome
Comment 6 Petr Jiricka 2013-05-26 22:07:14 UTC
Created attachment 134924 [details]
stacktrace

Selected element in Chrome while in inspect mode.
Comment 7 Petr Jiricka 2013-05-27 07:23:30 UTC
Always reproducible -> P2.
Comment 8 Jan Stola 2013-05-27 11:40:14 UTC
This exception is caused by an incompatible change in CSS domain of WebKit Remote Debugging protocol, see

https://chromium.googlesource.com/chromium/blink/+/fd5d5894bfe7e4507abe4a51e2ebfd4777dc5a4b%5E%21/#F17

SourceRange.start and SourceRange.end were removed and replaced by SourceRange.startLine/startColumn/endLine/endColumn.
Comment 9 Vladimir Riha 2013-05-27 11:46:14 UTC
Created attachment 134944 [details]
stacktrace

selected body element in Browser DOM in PhoneGap sample project while it was running in Chrome
Comment 10 Jan Stola 2013-05-27 13:39:55 UTC
Fixed by http://hg.netbeans.org/web-main/rev/8aa4d9846121
Comment 11 Petr Jiricka 2013-05-28 13:46:43 UTC
Honza Stola realized that this also affects 7.3.x users. Is this a 7.3.1 stopper?
Comment 12 Marian Mirilovic 2013-05-28 13:50:31 UTC
(In reply to comment #11)
> Honza Stola realized that this also affects 7.3.x users. Is this a 7.3.1
> stopper?

Agreed ...

Honza, please integrate into releases/rlease73 today. Thanks in advance.
Comment 13 Vladimir Riha 2013-05-28 14:15:59 UTC
verified in web-main - I tried to select element in browser/Browser DOM and add/edit/remove some css property


Product Version: NetBeans IDE Dev (Build web-main-10638-on-20130528)
Java: 1.7.0_15; Java HotSpot(TM) Client VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_15-b03
System: Windows 8 version 6.2 running on x86; Cp1252; en_US (nb)
Comment 14 Jan Stola 2013-05-28 17:03:26 UTC
I have integrated the fix into release73 branch.

Modified files: http://hg.netbeans.org/releases/rev/35ee5a09d520
Comment 15 Vladimir Riha 2013-05-29 07:51:10 UTC
changing keyword to HR_FIX
Comment 16 Jan Stola 2013-06-03 07:45:32 UTC
*** Bug 230602 has been marked as a duplicate of this bug. ***
Comment 17 Vladimir Riha 2013-06-04 06:27:03 UTC
*** Bug 230692 has been marked as a duplicate of this bug. ***
Comment 18 Vladimir Riha 2013-06-05 21:19:21 UTC
*** Bug 230791 has been marked as a duplicate of this bug. ***
Comment 19 Vladimir Riha 2013-06-07 08:49:14 UTC
verified in 7.3.1

Product Version: NetBeans IDE 7.3.1 (Build 201306052037)
Java: 1.7.0_25; Java HotSpot(TM) Client VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b15
System: Linux version 3.2.0-45-generic-pae running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo