Bug 227912 - org.netbeans.modules.masterfs.filebasedfs.FileBasedFileSystem.getFileObject: LowPerformance took 23395 ms.
org.netbeans.modules.masterfs.filebasedfs.FileBasedFileSystem.getFileObject: ...
Status: RESOLVED DUPLICATE of bug 227296
Product: javascript
Classification: Unclassified
Component: Editor
7.2
All All
: P3 (vote)
: TBD
Assigned To: Petr Pisl
issues@javascript
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 239623 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-25 15:42 UTC by Exceptions Reporter
Modified: 2013-12-19 08:17 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (42.86 KB, application/nps)
2013-03-25 15:42 UTC, Exceptions Reporter
Details
nps snapshot (34.04 KB, application/nps)
2013-06-04 13:22 UTC, rptmaestro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-03-25 15:42:56 UTC
Build: NetBeans IDE 7.2 (Build 201207301726)
VM: OpenJDK 64-Bit Server VM, 23.7-b01, OpenJDK Runtime Environment, 1.7.0_09-icedtea-mockbuild_2013_03_05_06_18-b00
OS: Linux

User Comments:
GUEST: Netbeans startert with 16 proyects



Maximum slowness yet reported was 24852 ms, average is 24123
Comment 1 Exceptions Reporter 2013-03-25 15:42:58 UTC
Created attachment 133043 [details]
nps snapshot
Comment 2 rptmaestro 2013-06-04 13:22:28 UTC
Created attachment 135326 [details]
nps snapshot

Tried deleting a java file from my project view. IDE stopped responding for 14 seconds and the file was not deleted.
Comment 3 Jaroslav Havlin 2013-07-23 13:57:18 UTC
Method org.netbeans.modules.csl.navigation.ElementNode.getHtmlDisplayName() took 70 ms. The slowness was caused by very slow File.exists() called in EDT.
Please evaluate. Thank you.
Comment 4 Petr Hejl 2013-07-25 13:33:30 UTC

*** This bug has been marked as a duplicate of bug 227296 ***
Comment 5 Jaroslav Havlin 2013-12-19 08:17:53 UTC
*** Bug 239623 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo