Bug 227880 - moz-linear-gradient causes parser error
moz-linear-gradient causes parser error
Status: RESOLVED FIXED
Product: web
Classification: Unclassified
Component: CSS Editor
7.4
PC All
: P4 (vote)
: 8.1
Assigned To: Milutin Kristofic
Vladimir Riha
: REGRESSION
: 228987 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-25 07:38 UTC by Vladimir Riha
Modified: 2015-09-16 10:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2013-03-25 07:38:27 UTC
This is a regression from 7.3 and it causes css file and parent folder to have error badge. IMO it should be fixed for 7.4


Please try following in css file:

.test {
background: -moz-linear-gradient(center top, #f3f3f3, #dddddd);
}




Product Version: NetBeans IDE Dev (Build web-main-10157-on-20130325)
Java: 1.7.0_17; Java HotSpot(TM) Client VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_17-b02
System: Linux version 3.2.0-39-generic-pae running on i386; UTF-8; en_US (nb)
Comment 1 maxym 2013-03-25 15:53:05 UTC
Looks, it is considered as error every time first argument of gradient is build by 2 words. For example in case of "to bottom".
I suggest to verify all possible options to make sure all of them are considered correct.


background: -moz-linear-gradient(top,  #b02000 0%, #dc4a00 100%);
background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,#b02000), color-stop(100%,#dc4a00));
background: -webkit-linear-gradient(top,  #b02000 0%,#dc4a00 100%);
background: -o-linear-gradient(top,  #b02000 0%,#dc4a00 100%);
background: -ms-linear-gradient(top,  #b02000 0%,#dc4a00 100%);
background: linear-gradient(to bottom,  #b02000 0%,#dc4a00 100%);
Comment 2 Marek Fukala 2013-03-25 15:55:11 UTC
already fixed
Comment 3 Vladimir Riha 2013-03-26 07:11:34 UTC
I'm sorry but both samples above still show error


Product Version: NetBeans IDE Dev (Build web-main-10169-on-20130326)
Java: 1.7.0_17; Java HotSpot(TM) Client VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_17-b32
System: Linux version 3.2.0-39-generic-pae running on i386; UTF-8; en_US (nb)
Comment 4 Marek Fukala 2013-03-26 13:59:12 UTC
I'm sorry, now it is really fixed.

web-main#36960802b5d0
Comment 5 Quality Engineering 2013-03-27 02:08:08 UTC
Integrated into 'main-golden', will be available in build *201303262300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/36960802b5d0
User: Marek Fukala <mfukala@netbeans.org>
Log: #227880 - moz-linear-gradient causes parser error
Comment 6 Vladimir Riha 2013-03-27 10:32:15 UTC
Thanks, now it is OK


Product Version: NetBeans IDE Dev (Build web-main-10182-on-20130327)
Java: 1.7.0_17; Java HotSpot(TM) Client VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_17-b32
System: Linux version 3.2.0-39-generic-pae running on i386; UTF-8; en_US (nb)
Comment 7 Vladimir Riha 2013-04-25 06:24:27 UTC
*** Bug 228987 has been marked as a duplicate of this bug. ***
Comment 8 _ gtzabari 2013-06-22 01:57:52 UTC
Product Version: NetBeans IDE Dev (Build 201306202301)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b16
System: Windows 7 version 6.1 running on amd64; Cp1252; en_CA (nb)
User directory: C:\Users\Gili\AppData\Roaming\NetBeans\dev
Cache directory: C:\Users\Gili\AppData\Local\NetBeans\Cache\dev

The issue is still reproducible for:

background-image: linear-gradient(to left, rgba(79,99,31,1) 0%,rgba(47,67,33,1) 44%,rgba(20,45,19,1) 100%);
Comment 9 Marek Fukala 2013-06-24 12:47:30 UTC
reproducible, I've added new testcases to the Css3ParserTest.testFunctionArgumentWithMultipleTermsSeparatedByWS() test, will fix later
Comment 10 DamienOND 2014-10-23 15:07:35 UTC
Still present in 8.0.1, e.g.

background-image: linear-gradient(to bottom, #0088CC, #0044CC);

Produces the 'Unexpected character(s)' warning.
Comment 11 Tekime 2014-11-24 07:54:40 UTC
Another case still happening in 8.0.1, triggered by "to bottom":

background: linear-gradient(to bottom,  rgba(125,126,125,1) 0%,rgba(14,14,14,1) 100%);

Workaround: you can safely swap out "to bottom" for "180deg", eg:

background: linear-gradient(180deg,  rgba(125,126,125,1) 0%,rgba(14,14,14,1) 100%);
Comment 12 Milutin Kristofic 2015-08-12 14:13:38 UTC
Fixed in #244711
Comment 13 danysan 2015-09-14 21:15:27 UTC
Product Version: NetBeans IDE 8.0.2 (Build 201411181905)
Updates: NetBeans IDE is updated to version NetBeans 8.0.2 Patch 2
Java: 1.8.0_60; Java HotSpot(TM) 64-Bit Server VM 25.60-b23
Runtime: Java(TM) SE Runtime Environment 1.8.0_60-b27
System: Windows 10 version 10.0 running on amd64; Cp1252; it_IT (nb)

The issue is still open here, triggered by:

background:linear-gradient(to bottom, #768d87 5%, #6c7c7c 100%);

and by:

background:linear-gradient(to bottom, #6c7c7c 5%, #768d87 100%);
Comment 14 Milutin Kristofic 2015-09-16 10:31:42 UTC
You have old build. It was fixed for 8.1. Try 8.1 Beta, or dev build. Thank you


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo