Bug 227805 - org.netbeans.modules.masterfs.filebasedfs.utils.FileInfo.isDirectory: LowPerformance took 47236 ms.
org.netbeans.modules.masterfs.filebasedfs.utils.FileInfo.isDirectory: LowPerf...
Status: RESOLVED DUPLICATE of bug 225955
Product: versioncontrol
Classification: Unclassified
Component: Code
7.3
All All
: P3 (vote)
: 7.4
Assigned To: Tomas Stupka
diff-issues@utilities
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-22 09:57 UTC by Exceptions Reporter
Modified: 2013-08-16 09:40 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (50.06 KB, application/nps)
2013-03-22 09:57 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-03-22 09:57:53 UTC
Build: NetBeans IDE 7.3 (Build 201302132200)
VM: Java HotSpot(TM) Client VM, 23.7-b01, Java(TM) SE Runtime Environment, 1.7.0_17-b02
OS: Windows Vista
Maximum slowness yet reported was 47236 ms, average is 42781
Comment 1 Exceptions Reporter 2013-03-22 09:57:56 UTC
Created attachment 132936 [details]
nps snapshot
Comment 2 Jaroslav Havlin 2013-08-16 08:56:09 UTC
Method o.n.m.versioning.ui.diff.DiffSidebar.shutdown() removes a file change listener in EDT. Resulting invocation of File.isDirectory was quite slow on Windows filesystem.

Closing as wontfix is probably acceptable.
Reassigning. Please evaluate. Thanks.
Comment 3 Ondrej Vrabec 2013-08-16 09:40:44 UTC
> Method o.n.m.versioning.ui.diff.DiffSidebar.shutdown() removes a file change listener in EDT.
Not any more in recent dev builds. Already fixed.

*** This bug has been marked as a duplicate of bug 225955 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo