Bug 225955 - org.netbeans.modules.masterfs.watcher.Watcher$Ext.register: LowPerformance took 3960 ms.
org.netbeans.modules.masterfs.watcher.Watcher$Ext.register: LowPerformance to...
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Code
7.3
All All
: P3 (vote)
: 7.4
Assigned To: Tomas Stupka
issues@versioncontrol
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 227805 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-10 17:35 UTC by Exceptions Reporter
Modified: 2013-08-16 09:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (15.06 KB, application/nps)
2013-02-10 17:35 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-02-10 17:35:23 UTC
This bug was originally marked as duplicate of bug 207810, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.5-b02, Java(TM) SE Runtime Environment, 1.7.0_09-b05
OS: Windows 7
Maximum slowness yet reported was 3960 ms, average is 3960
Comment 1 Exceptions Reporter 2013-02-10 17:35:27 UTC
Created attachment 131210 [details]
nps snapshot
Comment 2 Jaroslav Havlin 2013-07-26 07:32:34 UTC
DiffSidebar.initialize() is adding a file listener in EDT.
Reassigning. Please evaluate.
Comment 3 Ondrej Vrabec 2013-07-26 08:19:56 UTC
although it appears to be a stuck native window file system it's true we should not access FS in EDT.

fix: http://hg.netbeans.org/core-main/rev/0f7fa90b398b
Comment 4 Quality Engineering 2013-07-27 02:19:57 UTC
Integrated into 'main-silver', will be available in build *201307262300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/0f7fa90b398b
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #225955 - org.netbeans.modules.masterfs.watcher.Watcher$Ext.register: LowPerformance took 3960 ms.
do not attach or detach filechange listeners in EDT
Comment 5 Ondrej Vrabec 2013-08-16 09:40:44 UTC
*** Bug 227805 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo