Bug 225451 - IndexOutOfBoundsException: Invalid line index=1 >= lineCount=1
IndexOutOfBoundsException: Invalid line index=1 >= lineCount=1
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.3
All All
: P1 (vote)
: 7.3
Assigned To: Miloslav Metelka
issues@editor
EXCEPTIONS_REPORT
: 73_HR_FIX
: 217103 225327 225362 225363 225690 225821 225841 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 08:32 UTC by Vladimir Voskresensky
Modified: 2013-02-14 11:59 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.02 KB, text/plain)
2013-01-29 08:32 UTC, Vladimir Voskresensky
Details
stacktrace (4.24 KB, text/plain)
2013-01-31 18:31 UTC, misterm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Voskresensky 2013-01-29 08:32:24 UTC
This issue was reported manually by vv159170.
It already has 2 duplicates 


Build: NetBeans IDE Dev (Build 20130125-af25d6f79fe6)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.10-b01, Java(TM) SE Runtime Environment, 1.6.0_35-b10
OS: Linux

User Comments:
vv159170: revert file




Stacktrace: 
java.lang.IndexOutOfBoundsException: Invalid line index=1 >= lineCount=1
   at org.netbeans.modules.editor.lib2.document.LineRootElement.getElement(LineRootElement.java:84)
   at org.netbeans.modules.editor.lib2.view.HighlightsViewFactory.updateLineEndOffset(HighlightsViewFactory.java:344)
   at org.netbeans.modules.editor.lib2.view.HighlightsViewFactory.createView(HighlightsViewFactory.java:218)
   at org.netbeans.modules.editor.lib2.view.ViewBuilder.createNextView(ViewBuilder.java:898)
   at org.netbeans.modules.editor.lib2.view.ViewBuilder.createViews(ViewBuilder.java:735)
   at org.netbeans.modules.editor.lib2.view.ViewBuilder.createReplaceRepaintViews(ViewBuilder.java:689)
Comment 1 Vladimir Voskresensky 2013-01-29 08:32:26 UTC
Created attachment 130764 [details]
stacktrace
Comment 2 Vladimir Voskresensky 2013-01-29 08:49:38 UTC
Mila, this exception is rather dangerous, because vcs revert has happened, but displayed file content was not refreshed => have to close and reopen file, although file status is unmodified
Comment 3 Miloslav Metelka 2013-01-30 16:50:09 UTC
You're right, Vladimir, raising to P1.
After many tries and writing several tests I've finally found a way (thanks to Jirka Prox) to reproduce the problem consistently.
Comment 4 misterm 2013-01-31 18:31:52 UTC
Created attachment 130907 [details]
stacktrace
Comment 5 Miloslav Metelka 2013-02-03 09:52:29 UTC
http://hg.netbeans.org/jet-main/rev/f77dd1c30480
Comment 6 Marian Mirilovic 2013-02-03 18:04:55 UTC
Mila, 
if you plan to fix it in 7.3, please integrate the fix into release73 today. Thanks in advance. Otherwise we will fix it in a patch 1
Comment 7 Miloslav Metelka 2013-02-03 18:51:30 UTC
Yes, I was just waiting for cont.build results, it looks ok.
Integrated into release73:
f77dd1c30480 transplanted to e6f879be3abf
Comment 8 Miloslav Metelka 2013-02-03 19:18:50 UTC
Removed extra variables from ViewBuilder.toString() introduced by a changeset not present in release73:
http://hg.netbeans.org/releases/rev/af270be4ed2f
Comment 9 Quality Engineering 2013-02-04 01:16:38 UTC
Integrated into 'releases', will be available in build *201302032200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/e6f879be3abf
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #225451 - IndexOutOfBoundsException: Invalid line index=1 >= lineCount=1.
(transplanted from f77dd1c30480c7a230dc50ee603489ad2122b137)
Comment 10 Quality Engineering 2013-02-04 03:16:21 UTC
Integrated into 'main-golden', will be available in build *201302040001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/f77dd1c30480
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #225451 - IndexOutOfBoundsException: Invalid line index=1 >= lineCount=1.
Comment 11 Miloslav Metelka 2013-02-04 10:16:20 UTC
*** Bug 225690 has been marked as a duplicate of this bug. ***
Comment 12 Miloslav Metelka 2013-02-04 13:07:32 UTC
*** Bug 225362 has been marked as a duplicate of this bug. ***
Comment 13 Jiri Prox 2013-02-04 15:38:20 UTC
verified
Comment 14 Miloslav Metelka 2013-02-06 14:37:31 UTC
*** Bug 225363 has been marked as a duplicate of this bug. ***
Comment 15 Milutin Kristofic 2013-02-07 12:50:27 UTC
*** Bug 225821 has been marked as a duplicate of this bug. ***
Comment 16 Jiri Prox 2013-02-07 17:52:43 UTC
*** Bug 225327 has been marked as a duplicate of this bug. ***
Comment 17 Miloslav Metelka 2013-02-07 20:34:01 UTC
*** Bug 225841 has been marked as a duplicate of this bug. ***
Comment 18 Miloslav Metelka 2013-02-14 11:59:47 UTC
*** Bug 217103 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo