Bug 225690 - Can't Delete Text In Java File
Can't Delete Text In Java File
Status: RESOLVED DUPLICATE of bug 225451
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
7.3
PC Windows 7
: P1 (vote)
: 7.3
Assigned To: Miloslav Metelka
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-04 09:58 UTC by MackSix
Modified: 2013-02-04 10:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Project to use for reproduction. (347.98 KB, application/zip)
2013-02-04 10:00 UTC, MackSix
Details
Code to paste into project. (6.45 KB, text/plain)
2013-02-04 10:00 UTC, MackSix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MackSix 2013-02-04 09:58:12 UTC
1. Open up attached Project in NetBeans.
2. Open up attached text file in Windows Notepad.
3. Highlight all the code in the text file and copy.
4. Open ConsolidatorDemo.java file in editor and paste the code into the file.
5. Place cursor at the top of file and press Shift+Ctrl+End to highlight all the text and press Delete.
6. Paste the code into the ConsolidatorDemo.java file again in Editor.
7. Repeat step 5.
8. Notice the text will not delete. Backspace does not work either as well as typing a character. 

Workaround: Close file and reopen it.

This does not happen in NetBeans v7.2.1 - regression.

Product Version: NetBeans IDE 7.3 RC1 (Build 201301240957)
Java: 1.7.0_13; Java HotSpot(TM) 64-Bit Server VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_13-b20
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 1 MackSix 2013-02-04 10:00:08 UTC
Created attachment 130980 [details]
Project to use for reproduction.
Comment 2 MackSix 2013-02-04 10:00:37 UTC
Created attachment 130981 [details]
Code to paste into project.
Comment 3 Miloslav Metelka 2013-02-04 10:16:19 UTC
This is a dup of issue #225451. When going through the steps on the build that includes the fix it works ok.

*** This bug has been marked as a duplicate of bug 225451 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo