Bug 224740 - NullPointerException at org.netbeans.modules.java.source.PostFlowAnalysis.visitMethodDef
NullPointerException at org.netbeans.modules.java.source.PostFlowAnalysis.vis...
Status: RESOLVED DUPLICATE of bug 249472
Product: java
Classification: Unclassified
Component: Compiler
7.3
All All
: P2 with 1 vote (vote)
: Dev
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
: 249597 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-11 07:18 UTC by jmichelberger
Modified: 2015-02-09 09:57 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.90 KB, text/plain)
2013-01-11 07:18 UTC, jmichelberger
Details
stacktrace (8.41 KB, text/plain)
2014-10-07 09:26 UTC, Alexander Simon
Details
stacktrace (5.98 KB, text/plain)
2014-10-08 08:30 UTC, Alexander Simon
Details
stacktrace (5.63 KB, text/plain)
2014-12-12 14:37 UTC, alied
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jmichelberger 2013-01-11 07:18:01 UTC
This bug was originally marked as duplicate of bug 214686, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) Client VM, 23.3-b01, Java(TM) SE Runtime Environment, 1.7.0_07-b11
OS: Windows 7

Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.java.source.PostFlowAnalysis.visitMethodDef(PostFlowAnalysis.java:167)
   at com.sun.tools.javac.tree.JCTree$JCMethodDecl.accept(JCTree.java:672)
   at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:49)
   at org.netbeans.modules.java.source.PostFlowAnalysis.scan(PostFlowAnalysis.java:128)
   at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:57)
   at com.sun.tools.javac.tree.TreeScanner.visitClassDef(TreeScanner.java:80)
Comment 1 jmichelberger 2013-01-11 07:18:02 UTC
Created attachment 130098 [details]
stacktrace
Comment 2 Alexander Simon 2014-10-07 09:26:59 UTC
Created attachment 149758 [details]
stacktrace

debug
Comment 3 Alexander Simon 2014-10-08 08:30:04 UTC
Created attachment 149780 [details]
stacktrace

edit code
Comment 4 Alexander Simon 2014-10-08 08:39:55 UTC
P2 because 15 + 7 (from bug #214686) reports
Very annoyed exception report makes impossible to edit file.
Comment 5 Leperous 2014-10-29 10:21:12 UTC
Getting this on an anonymous Java 8 class that extends an abstract class. If I save the class, Netbeans hangs and has to be restarted!
Comment 6 alied 2014-12-12 14:37:35 UTC
Created attachment 151079 [details]
stacktrace

editing a test file of a gradle project
Comment 7 Dusan Balek 2015-01-05 10:36:25 UTC
*** Bug 249597 has been marked as a duplicate of this bug. ***
Comment 8 Dusan Balek 2015-02-09 09:57:21 UTC
Already fixed in dev build.

*** This bug has been marked as a duplicate of bug 249472 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo