Bug 249472 - An error occurred during parsing of PanelGlobalOptionEdit.java
An error occurred during parsing of PanelGlobalOptionEdit.java
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Source
8.0.2
PC Linux
: P2 (vote)
: 8.1
Assigned To: Svata Dedic
issues@java
:
: 224740 247362 250511 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-20 17:56 UTC by mclaborn
Modified: 2015-04-16 18:56 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Dump file (88.25 KB, application/octet-stream)
2014-12-20 17:58 UTC, mclaborn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mclaborn 2014-12-20 17:56:54 UTC
Product Version = NetBeans IDE 8.0.2 (Build 201408251540)
Operating System = Linux version 3.13.0-43-generic running on amd64
Java; VM; Vendor = 1.7.0_72
Runtime = Java HotSpot(TM) 64-Bit Server VM 24.72-b04

Annotation: An error occurred during parsing of '/home/mclaborn/projects/NetBeans/MMGUI/MiscMaint/src/com/csc/mm/miscmaint/PanelGlobalOptionEdit.java'. Please report a bug against java/source and attach dump file '/home/mclaborn/.netbeans/8.0/var/log/PanelGlobalOptionEdit_22.dump'.
Annotation: An error occurred during parsing of '/home/mclaborn/projects/NetBeans/MMGUI/MiscMaint/src/com/csc/mm/miscmaint/PanelGlobalOptionEdit.java'. Please report a bug against java/source and attach dump file '/home/mclaborn/.netbeans/8.0/var/log/PanelGlobalOptionEdit_22.dump'.
An error occurred during parsing of '/home/mclaborn/projects/NetBeans/MMGUI/MiscMaint/src/com/csc/mm/miscmaint/PanelGlobalOptionEdit.java'. Please report a bug against java/source and attach dump file '/home/mclaborn/.netbeans/8.0/var/log/PanelGlobalOptionEdit_22.dump'.
An error occurred during parsing of '/home/mclaborn/projects/NetBeans/MMGUI/MiscMaint/src/com/csc/mm/miscmaint/PanelGlobalOptionEdit.java'. Please report a bug against java/source and attach dump file '/home/mclaborn/.netbeans/8.0/var/log/PanelGlobalOptionEdit_22.dump'.
Caused: java.lang.NullPointerException
	at org.netbeans.modules.java.source.PostFlowAnalysis.visitMethodDef(PostFlowAnalysis.java:171)
	at com.sun.tools.javac.tree.JCTree$JCMethodDecl.accept(JCTree.java:784)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:49)
	at org.netbeans.modules.java.source.PostFlowAnalysis.scan(PostFlowAnalysis.java:132)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:57)
	at com.sun.tools.javac.tree.TreeScanner.visitClassDef(TreeScanner.java:80)
	at org.netbeans.modules.java.source.PostFlowAnalysis.visitClassDef(PostFlowAnalysis.java:144)
	at com.sun.tools.javac.tree.JCTree$JCClassDecl.accept(JCTree.java:698)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:49)
	at org.netbeans.modules.java.source.PostFlowAnalysis.scan(PostFlowAnalysis.java:132)
	at com.sun.tools.javac.tree.TreeScanner.visitNewClass(TreeScanner.java:208)
	at org.netbeans.modules.java.source.PostFlowAnalysis.visitNewClass(PostFlowAnalysis.java:184)
	at com.sun.tools.javac.tree.JCTree$JCNewClass.accept(JCTree.java:1522)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:49)
	at org.netbeans.modules.java.source.PostFlowAnalysis.scan(PostFlowAnalysis.java:132)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:57)
	at com.sun.tools.javac.tree.TreeScanner.visitApply(TreeScanner.java:200)
	at org.netbeans.modules.java.source.PostFlowAnalysis.visitApply(PostFlowAnalysis.java:208)
	at com.sun.tools.javac.tree.JCTree$JCMethodInvocation.accept(JCTree.java:1471)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:49)
	at org.netbeans.modules.java.source.PostFlowAnalysis.scan(PostFlowAnalysis.java:132)
	at com.sun.tools.javac.tree.TreeScanner.visitExec(TreeScanner.java:175)
	at com.sun.tools.javac.tree.JCTree$JCExpressionStatement.accept(JCTree.java:1302)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:49)
	at org.netbeans.modules.java.source.PostFlowAnalysis.scan(PostFlowAnalysis.java:132)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:57)
	at com.sun.tools.javac.tree.TreeScanner.visitBlock(TreeScanner.java:105)
	at com.sun.tools.javac.tree.JCTree$JCBlock.accept(JCTree.java:915)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:49)
	at org.netbeans.modules.java.source.PostFlowAnalysis.scan(PostFlowAnalysis.java:132)
	at com.sun.tools.javac.tree.TreeScanner.visitMethodDef(TreeScanner.java:91)
	at org.netbeans.modules.java.source.PostFlowAnalysis.visitMethodDef(PostFlowAnalysis.java:166)
	at com.sun.tools.javac.tree.JCTree$JCMethodDecl.accept(JCTree.java:784)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:49)
	at org.netbeans.modules.java.source.PostFlowAnalysis.scan(PostFlowAnalysis.java:132)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:57)
	at com.sun.tools.javac.tree.TreeScanner.visitClassDef(TreeScanner.java:80)
	at org.netbeans.modules.java.source.PostFlowAnalysis.visitClassDef(PostFlowAnalysis.java:144)
	at com.sun.tools.javac.tree.JCTree$JCClassDecl.accept(JCTree.java:698)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:49)
	at org.netbeans.modules.java.source.PostFlowAnalysis.scan(PostFlowAnalysis.java:132)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:57)
	at com.sun.tools.javac.tree.TreeScanner.visitTopLevel(TreeScanner.java:68)
	at com.sun.tools.javac.tree.JCTree$JCCompilationUnit.accept(JCTree.java:520)
	at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:49)
	at org.netbeans.modules.java.source.PostFlowAnalysis.scan(PostFlowAnalysis.java:132)
	at org.netbeans.modules.java.source.PostFlowAnalysis.analyze(PostFlowAnalysis.java:110)
	at org.netbeans.modules.java.source.parsing.JavacParser.moveToPhase(JavacParser.java:664)
	at org.netbeans.modules.java.source.parsing.JavacParser.getResult(JavacParser.java:519)
	at org.netbeans.modules.java.source.parsing.JavacParser.getResult(JavacParser.java:174)
	at org.netbeans.modules.parsing.impl.TaskProcessor.callGetResult(TaskProcessor.java:620)
	at org.netbeans.modules.parsing.impl.SourceCache.getResult(SourceCache.java:256)
[catch] at org.netbeans.modules.parsing.impl.TaskProcessor$CompilationJob.run(TaskProcessor.java:733)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1423)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2033)
Comment 1 mclaborn 2014-12-20 17:58:04 UTC
Created attachment 151224 [details]
Dump file
Comment 2 Svata Dedic 2015-01-06 15:01:03 UTC
NPE avoided in jet-main#925fcafec741
Comment 3 Quality Engineering 2015-01-10 18:26:30 UTC
Integrated into 'main-silver', will be available in build *201501101317* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/925fcafec741
User: Svata Dedic <sdedic@netbeans.org>
Log: #249472: avoid NPE on erroneous symbols
Comment 4 Dusan Balek 2015-02-09 09:57:21 UTC
*** Bug 224740 has been marked as a duplicate of this bug. ***
Comment 5 Svata Dedic 2015-02-09 13:21:43 UTC
*** Bug 247362 has been marked as a duplicate of this bug. ***
Comment 6 Alexander Simon 2015-02-13 09:39:54 UTC
What is about porting the fix in 802patch1?
Comment 7 Dusan Balek 2015-02-27 10:06:35 UTC
*** Bug 250511 has been marked as a duplicate of this bug. ***
Comment 8 angstadt530 2015-04-16 18:56:01 UTC
Are there any plans for a patch or an 8.0.3 release for this fix?  8.1 is not scheduled until Oct 15 and this issue occurs frequently.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo