Bug 224122 - IllegalStateException: Too many repetitions in getNodes(true). Giving up.
IllegalStateException: Too many repetitions in getNodes(true). Giving up.
Status: RESOLVED DUPLICATE of bug 221279
Product: platform
Classification: Unclassified
Component: Nodes
7.3
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-21 08:02 UTC by sdlarsen
Modified: 2012-12-22 06:40 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.22 KB, text/plain)
2012-12-21 08:02 UTC, sdlarsen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sdlarsen 2012-12-21 08:02:45 UTC
Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: OpenJDK 64-Bit Server VM, 23.2-b09, OpenJDK Runtime Environment, 1.7.0_09-b30
OS: Linux

User Comments:
sdlarsen: Closing a file after returning to the IDE from command-line maven build

mcdev1: Opened a class file from the Usages window.

GUEST: just openeing a java file




Stacktrace: 
java.lang.IllegalStateException: Too many repetitions in getNodes(true). Giving up.
   at org.openide.loaders.FolderChildren.getNodes(FolderChildren.java:288)
   at org.openide.nodes.FilterNode$Children$LazySupport.callGetNodes(FilterNode.java:1767)
   at org.openide.nodes.FilterNode$Children.getNodes(FilterNode.java:1606)
   at org.netbeans.spi.java.project.support.ui.PackageRootNode$PathFinder.findPath(PackageRootNode.java:417)
   at org.netbeans.spi.java.project.support.ui.PackageView.findPath(PackageView.java:126)
   at org.netbeans.modules.maven.LogicalViewProviderImpl.findPath(LogicalViewProviderImpl.java:119)
Comment 1 sdlarsen 2012-12-21 08:02:47 UTC
Created attachment 129611 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-12-22 06:40:34 UTC

*** This bug has been marked as a duplicate of bug 221279 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo