Bug 221279 - 100% cpu with Lazy Node Children: Too many repetitions in getNodes(true). Giving up.
100% cpu with Lazy Node Children: Too many repetitions in getNodes(true). Giv...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Data Systems
7.3
All All
: P2 (vote)
: 7.3
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
: 215472 217999 221502 221522 221750 222189 222485 223551 224122 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-01 18:29 UTC by lehel
Modified: 2012-12-22 06:40 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.41 KB, text/plain)
2012-11-01 18:29 UTC, lehel
Details
IDE log with thread dump. (27.88 KB, application/octet-stream)
2012-11-13 10:55 UTC, Jiri Skrivanek
Details
stacktrace (3.49 KB, text/plain)
2012-11-19 10:01 UTC, Exceptions Reporter
Details
Log from tests on build 201212050001. (1.75 MB, text/plain)
2012-12-05 08:05 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lehel 2012-11-01 18:29:41 UTC
Build: NetBeans IDE Dev (Build 201211010001)
VM: Java HotSpot(TM) Client VM, 23.5-b02, Java(TM) SE Runtime Environment, 1.7.0_09-b05
OS: Windows XP

User Comments:
lehel: Testing J2me CDC applications. 
Creating all type of Xlet files




Stacktrace: 
java.lang.IllegalStateException: Too many repetitions in getNodes(true). Giving up.
   at org.openide.loaders.FolderChildren.getNodes(FolderChildren.java:288)
   at org.openide.nodes.FilterNode$Children$LazySupport.callGetNodes(FilterNode.java:1767)
   at org.openide.nodes.FilterNode$Children.getNodes(FilterNode.java:1606)
   at org.netbeans.spi.java.project.support.ui.PackageRootNode$PathFinder.findPath(PackageRootNode.java:417)
   at org.netbeans.spi.java.project.support.ui.PackageView.findPath(PackageView.java:126)
   at org.netbeans.modules.mobility.project.ui.J2MEPhysicalViewProvider.findPath(J2MEPhysicalViewProvider.java:102)
Comment 1 lehel 2012-11-01 18:29:43 UTC
Created attachment 126942 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-11-02 08:20:55 UTC
Thanks for the report.
Comment 3 Jaroslav Tulach 2012-11-05 11:35:41 UTC
*** Bug 215472 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Tulach 2012-11-05 14:29:02 UTC
Will need new log with dump of stack of threads: ergonomics#00998f6498a9
Comment 5 Jaroslav Tulach 2012-11-06 11:27:21 UTC
*** Bug 221522 has been marked as a duplicate of this bug. ***
Comment 6 Jaroslav Tulach 2012-11-06 11:33:05 UTC
*** Bug 217999 has been marked as a duplicate of this bug. ***
Comment 7 Jaroslav Tulach 2012-11-06 11:33:36 UTC
*** Bug 221502 has been marked as a duplicate of this bug. ***
Comment 8 Jaroslav Tulach 2012-11-06 12:59:48 UTC
Actually the log from bug 221502 is what I was searching for:
http://netbeans.org/bugzilla/attachment.cgi?id=127163
there is no sign of DataNode processing thread to be blocked.
Comment 9 Jaroslav Tulach 2012-11-06 13:09:05 UTC
Another attempt: ergonomics#3ca317c06988
Comment 10 Quality Engineering 2012-11-07 03:41:38 UTC
Integrated into 'main-golden', will be available in build *201211070001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/00998f6498a9
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #221279: Try to also print what the other threads are doing
Comment 12 Jaroslav Tulach 2012-11-07 13:37:21 UTC
Probably I should learn to code: ergonomics#c777fdc426c2
Comment 13 Quality Engineering 2012-11-08 02:52:40 UTC
Integrated into 'main-golden', will be available in build *201211080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/3ca317c06988
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #221279: Force the refresh in case the repetition takes too long
Comment 14 Quality Engineering 2012-11-09 02:50:49 UTC
Integrated into 'main-golden', will be available in build *201211090001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/c777fdc426c2
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #221279: Really print dump of all threads
Comment 15 Jaroslav Tulach 2012-11-09 13:59:00 UTC
*** Bug 221750 has been marked as a duplicate of this bug. ***
Comment 16 Jiri Skrivanek 2012-11-13 10:54:07 UTC
It happened again in tests. Please, evaluate logs with thread dumps.

java.lang.IllegalStateException: Too many repetitions in getNodes(true). Giving up.

http://hudson4qe.cz.oracle.com/view/Trunk-QE/job/CV-multi-UI/690/jdk=JDK%207,label=XP-slave3/testReport/org.netbeans.test.ide/IDECommitValidationTest/testProjectsView/

http://hudson4qe.cz.oracle.com/view/Trunk-QE/job/CV-multi-UI/690/jdk=JDK%207,label=XP-slave3/consoleText
Comment 17 Jiri Skrivanek 2012-11-13 10:55:04 UTC
Created attachment 127697 [details]
IDE log with thread dump.
Comment 18 Jaroslav Tulach 2012-11-14 10:47:59 UTC
Yet more logging: ergonomics#4d4e7830aa10
Comment 19 Quality Engineering 2012-11-15 02:46:19 UTC
Integrated into 'main-golden', will be available in build *201211150001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4d4e7830aa10
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #221279: Logging to find out who is setting the task to non-null
Comment 20 Exceptions Reporter 2012-11-18 12:13:33 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=194409
Comment 21 Jaroslav Tulach 2012-11-19 09:05:01 UTC
*** Bug 222189 has been marked as a duplicate of this bug. ***
Comment 22 Exceptions Reporter 2012-11-19 10:01:32 UTC
Created attachment 128040 [details]
stacktrace
Comment 23 Jaroslav Tulach 2012-11-23 08:01:34 UTC
*** Bug 222485 has been marked as a duplicate of this bug. ***
Comment 24 Jiri Skrivanek 2012-12-05 08:04:28 UTC
Happened again in dev build 20121205001 in tests.
Comment 25 Jiri Skrivanek 2012-12-05 08:05:19 UTC
Created attachment 128867 [details]
Log from tests on build 201212050001.
Comment 26 Jaroslav Tulach 2012-12-05 12:15:48 UTC
ergonomics#007ca8e40d6e
Comment 27 Jaroslav Tulach 2012-12-10 12:36:55 UTC
*** Bug 223551 has been marked as a duplicate of this bug. ***
Comment 28 Quality Engineering 2012-12-12 02:47:05 UTC
Integrated into 'main-golden', will be available in build *201212120001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/007ca8e40d6e
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #221279: 100% cpu with Lazy Node Children: Too many repetitions in getNodes(true). Giving up.
#221279: Runnable passed to task = DataNodeUtils.reqProcessor().post(runnable) could finish sooner than the task field was assigned. Adding synchronization.
Comment 29 Jaroslav Tulach 2012-12-22 06:40:34 UTC
*** Bug 224122 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo