Bug 222772 - CodeCompletion took 4512 ms.
CodeCompletion took 4512 ms.
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 222773 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 16:03 UTC by Michel Graciano
Modified: 2012-11-26 16:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (97.57 KB, application/nps)
2012-11-26 16:03 UTC, Michel Graciano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2012-11-26 16:03:00 UTC
This issue was reported manually by hmichel.
It already has 1 duplicates 


Build: NetBeans IDE Dev (Build 20121124-34e96c4dea5b)
VM: Java HotSpot(TM) Client VM, 23.5-b02, Java(TM) SE Runtime Environment, 1.7.0_09-b05
OS: Linux

User Comments:
hmichel: Using CC at 'Custom creation code' for a component



Maximum slowness yet reported was 4512 ms, average is 4512
Comment 1 Michel Graciano 2012-11-26 16:03:04 UTC
Created attachment 128406 [details]
nps snapshot
Comment 2 Dusan Balek 2012-11-26 16:27:46 UTC
*** Bug 222773 has been marked as a duplicate of this bug. ***
Comment 3 Dusan Balek 2012-11-26 16:47:12 UTC
Time spent in the 'analyze' phase of the javac compilation that seems to be competing for an IO with a pending file systems refresh. As 'Please wait' is displayed in code completion meanwhile, closing as wontfix.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo