Bug 222499 - can't import 7.2 old configurations
can't import 7.2 old configurations
Status: RESOLVED WORKSFORME
Product: ide
Classification: Unclassified
Component: Import Settings
7.3
PC Linux
: P3 (vote)
: TBD
Assigned To: Theofanis Oikonomou
issues@platform
:
: 218880 222639 223294 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-21 02:48 UTC by fortruth
Modified: 2013-10-23 15:02 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
<无描述> (17.23 KB, image/png)
2012-11-21 02:49 UTC, fortruth
Details
IDE log (46.06 KB, text/plain)
2012-11-22 01:51 UTC, fortruth
Details
logs (608.75 KB, application/octet-stream)
2012-11-23 12:30 UTC, medeag
Details
messages.log (28.78 KB, text/plain)
2012-12-06 10:20 UTC, aldobrucale
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fortruth 2012-11-21 02:48:15 UTC
Product Version = NetBeans IDE Dev (Build 201211200002)
Operating System = Linux version 3.5.0-19-generic running on amd64
Java; VM; Vendor = 1.7.0_09
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.5-b02

first installation, an error popup. see the screenshot attachment.
Comment 1 fortruth 2012-11-21 02:49:04 UTC
Created attachment 128174 [details]
<无描述>
Comment 2 Marian Mirilovic 2012-11-21 07:23:03 UTC
Could you please attach messages.log file and reopen ? Thanks in advance. 
http://wiki.netbeans.org/FaqLogMessagesFile
Comment 3 fortruth 2012-11-22 01:51:35 UTC
the new messages.log that after remove  .dev  user_dir.
Comment 4 fortruth 2012-11-22 01:51:39 UTC
Created attachment 128235 [details]
IDE log
Comment 5 Theofanis Oikonomou 2012-11-22 10:34:02 UTC
From the log I see that the refactoring warm-up task is failing as it cannot locate some file. Could you please reopen describing the exact steps you take so that I can reproduce what is happening? Thank you
Comment 6 Theofanis Oikonomou 2012-11-23 10:55:26 UTC
*** Bug 222639 has been marked as a duplicate of this bug. ***
Comment 7 Jiri Rechtacek 2012-11-23 11:05:35 UTC
I'm guessing it was assigned to the Autoupdate by mistake.
Comment 8 Theofanis Oikonomou 2012-11-23 12:03:12 UTC
*** Bug 218880 has been marked as a duplicate of this bug. ***
Comment 9 medeag 2012-11-23 12:26:04 UTC
In my case

I have just removed older daily build  userdir  and tried install new one,  install was successful, first launch and got this error

I can reproduce this on my mac machine and windows machine
Comment 10 medeag 2012-11-23 12:30:27 UTC
Created attachment 128307 [details]
logs
Comment 11 Theofanis Oikonomou 2012-11-23 15:01:55 UTC
I am sorry but I cannot reproduce. I tried installing the same dev build both in default and non-default dir (~/bin/...) after removing the ~/.netbeans/dev dir. During first run I was offered to import settings from 7.2 and clicked Yes. No exception in my case.

The exception is raised when the etc/netbeans.import file is not found inside the installation_dir. In all the reports though the exceptions state that the netbeans.import file cannot be found inside the user_dir. 

It seems that some configuration is present in these cases that I cannot reproduce. Please reopen if you can reliably reproduce this describing the exact steps the exception is raised. Thank you
Comment 12 Theofanis Oikonomou 2012-12-06 09:46:15 UTC
*** Bug 223294 has been marked as a duplicate of this bug. ***
Comment 13 aldobrucale 2012-12-06 10:20:06 UTC
Created attachment 128945 [details]
messages.log

I'm still able to reproduce this bug with version 201212050001 just removing the dev user and cache directories. Is there any further information I can provide, besides the log file?

Build 201212060001 seems to work fine, so maybe WORKSFORME was ok.
Comment 14 Theofanis Oikonomou 2012-12-07 13:23:32 UTC
closing then since it works in latest build. Thank you
Comment 15 aldobrucale 2012-12-10 09:58:38 UTC
It happened again with build 201212090001. This time the last line in the log is:

WARNING [org.netbeans.core.startup.InstalledFileLocatorImpl]: no code name base passed when looking up modules at org.netbeans.upgrade.AutoUpgrade.copyToUserdir(AutoUpgrade.java:295)
INFO [org.netbeans.upgrade.AutoUpgrade]: Importing from /home/aldo/.netbeans/7.2 to /home/aldo/.netbeans/dev
Comment 16 Theofanis Oikonomou 2013-10-23 15:02:17 UTC
I still am not able to reproduce. On a second thought this looks like some problem with the cache. Could you please delete the cache directory, typically found in eg ~/.cache/netbeans/7.x, and retry? This will not remove any settings or anything else. Please reopen if you can reproduce even afer deleting the caches.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo