Bug 222267 - OutOfMemoryError: GC overhead limit exceeded
OutOfMemoryError: GC overhead limit exceeded
Status: RESOLVED INCOMPLETE
Product: javascript
Classification: Unclassified
Component: Editor
7.3
All All
: P3 (vote)
: TBD
Assigned To: Petr Hejl
issues@javascript
EXCEPTIONS_REPORT
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-16 12:38 UTC by augcampos
Modified: 2013-07-31 08:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (475 bytes, text/plain)
2012-11-16 12:38 UTC, augcampos
Details
stacktrace (475 bytes, text/plain)
2013-07-30 12:28 UTC, Ondrej Vrabec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description augcampos 2012-11-16 12:38:11 UTC
Build: NetBeans IDE Dev (Build 201211160001)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.5-b02, Java(TM) SE Runtime Environment, 1.7.0_09-b05
OS: Linux

Stacktrace: 
java.lang.OutOfMemoryError: GC overhead limit exceeded
   at java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.addConditionWaiter(AbstractQueuedSynchronizer.java:1857)
   at java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.awaitNanos(AbstractQueuedSynchronizer.java:2073)
   at java.util.concurrent.DelayQueue.take(DelayQueue.java:220)
   at javax.swing.TimerQueue.run(TimerQueue.java:171)
   at java.lang.Thread.run(Thread.java:722)
Comment 1 augcampos 2012-11-16 12:38:14 UTC
Created attachment 127931 [details]
stacktrace
Comment 2 Tomas Hurka 2012-11-16 15:17:45 UTC
OOME is caused by parsing very large javascript file - it has 970,000 characters.
Comment 3 Ondrej Vrabec 2013-07-30 12:28:01 UTC
Created attachment 137997 [details]
stacktrace

while debugging NetBeans and got down into JDK sources
Comment 4 Petr Hejl 2013-07-31 08:31:16 UTC
The last report from Ondrej is not related to JS.
Tomasi can you share the file with us? Is it still happening?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo