Bug 222130 - Navigator is flashing during changes in the editor.
Navigator is flashing during changes in the editor.
Status: VERIFIED FIXED
Product: javascript
Classification: Unclassified
Component: Editor
7.3
PC Linux
: P1 (vote)
: 7.3
Assigned To: Petr Pisl
issues@javascript
: 73_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-14 15:51 UTC by Petr Pisl
Modified: 2013-02-15 15:59 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Example file (176.67 KB, application/javascript)
2012-11-14 15:51 UTC, Petr Pisl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2012-11-14 15:51:09 UTC
Created attachment 127793 [details]
Example file

Open the attached file in the editor. Go to line 6843 and try to add some js code, for example varr tt = 10. Navigator is refreshed, but is flashing at least two times and some nodes are collapsed and expanded again.
Comment 1 Vladimir Riha 2013-01-15 11:36:05 UTC
Would be nice to fix it for 73patch, in large files it could cause minor hiccups in editor
Comment 2 Petr Pisl 2013-02-07 22:22:40 UTC
Fixed in web-main:
http://hg.netbeans.org/web-main/rev/ecd182c72383
Comment 3 Vladimir Riha 2013-02-08 08:41:17 UTC
I can't reproduce it anymore (also the busy state seems to be gone)


Product Version: NetBeans IDE Dev (Build web-main-9839-on-20130208)
Java: 1.7.0_15; Java HotSpot(TM) Client VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_15-b01
System: Linux version 3.2.0-35-generic-pae running on i386; UTF-8; en_US (nb)
Comment 4 Petr Pisl 2013-02-11 10:34:41 UTC
I have transplanted the fix into the 7.3 release due to the issue #225865.
http://hg.netbeans.org/releases/rev/98d8757b80ec
Comment 5 Quality Engineering 2013-02-14 01:06:14 UTC
Integrated into 'releases', will be available in build *201302132200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/98d8757b80ec
User: Petr Pisl <ppisl@netbeans.org>
Log: #222130 - Navigator is flashing during changes in the editor
(transplanted from ecd182c72383e11b9462f66745e93f7e0ec7b4bb)
Comment 6 everflux 2013-02-15 15:59:50 UTC
This might then fix http://netbeans.org/bugzilla/show_bug.cgi?id=220414 as well, I will check it with the latest build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo