Bug 221172 - !!WARNING!! Missing READ-LOCK when accessing TokenHierarchy from CompletionSupport.isIncludeCompletionEnabled
!!WARNING!! Missing READ-LOCK when accessing TokenHierarchy from CompletionSu...
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Editor
7.3
All All
: P3 with 1 vote (vote)
: 7.3
Assigned To: Vladimir Voskresensky
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-31 12:56 UTC by Alexander Simon
Modified: 2012-12-12 02:46 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2012-10-31 12:56:34 UTC
INFO [org.netbeans.spi.lexer.MutableTextInput]: !!WARNING!! Missing READ-LOCK when accessing TokenHierarchy: input-source:org.netbeans.modules.editor.NbEditorDocument@650cb3, mimeType='text/x-c++', kitClass=null, length=147, version=3, file=org.netbeans.modules.cnd.source.CCDataObject@866463[/home/alsimon/NetBeansProjects/Welcome_10/welcome.cc@c48d7924:129e211]
java.lang.Exception
	at org.netbeans.lib.lexer.TokenHierarchyOperation.ensureReadLocked(TokenHierarchyOperation.java:397)
	at org.netbeans.lib.lexer.TokenHierarchyOperation.tokenSequence(TokenHierarchyOperation.java:422)
	at org.netbeans.lib.lexer.TokenHierarchyOperation.tokenSequence(TokenHierarchyOperation.java:418)
	at org.netbeans.api.lexer.TokenHierarchy.tokenSequence(TokenHierarchy.java:186)
	at org.netbeans.api.lexer.TokenHierarchy.embeddedTokenSequences(TokenHierarchy.java:265)
	at org.netbeans.cnd.api.lexer.CndLexerUtilities.getCppTokenSequence(CndLexerUtilities.java:137)
	at org.netbeans.modules.cnd.completion.cplusplus.ext.CompletionSupport.isIncludeCompletionEnabled(CompletionSupport.java:158)
	at org.netbeans.modules.cnd.completion.cplusplus.ext.CompletionSupport.isPreprocCompletionEnabled(CompletionSupport.java:134)
	at org.netbeans.modules.cnd.completion.cplusplus.ext.CsmCompletionQuery._checkCondition(CsmCompletionQuery.java:258)
	at org.netbeans.modules.cnd.completion.cplusplus.ext.CsmCompletionQuery.checkCondition(CsmCompletionQuery.java:237)
	at org.netbeans.modules.cnd.completion.cplusplus.CsmCompletionProvider.createTask(CsmCompletionProvider.java:116)
	at org.netbeans.modules.editor.completion.CompletionImpl.completionQuery(CompletionImpl.java:697)
	at org.netbeans.modules.editor.completion.CompletionImpl.showCompletion(CompletionImpl.java:901)
	at org.netbeans.modules.editor.completion.CompletionImpl.access$2400(CompletionImpl.java:110)
	at org.netbeans.modules.editor.completion.CompletionImpl$CompletionShowAction.actionPerformed(CompletionImpl.java:1559)
	at org.netbeans.modules.editor.completion.CompletionImpl.dispatchKeyEvent(CompletionImpl.java:621)
	at org.netbeans.modules.editor.completion.CompletionImpl.keyPressed(CompletionImpl.java:381)
	at java.awt.AWTEventMulticaster.keyPressed(AWTEventMulticaster.java:233)
	at java.awt.AWTEventMulticaster.keyPressed(AWTEventMulticaster.java:232)
	at java.awt.Component.processKeyEvent(Component.java:6248)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2801)
	at java.awt.Component.processEvent(Component.java:6067)
	at java.awt.Container.processEvent(Container.java:2039)
	at java.awt.Component.dispatchEventImpl(Component.java:4653)
	at java.awt.Container.dispatchEventImpl(Container.java:2097)
	at java.awt.Component.dispatchEvent(Component.java:4481)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1836)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:712)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:990)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:855)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:676)
	at java.awt.Component.dispatchEventImpl(Component.java:4525)
	at java.awt.Container.dispatchEventImpl(Container.java:2097)
	at java.awt.Window.dispatchEventImpl(Window.java:2482)
	at java.awt.Component.dispatchEvent(Component.java:4481)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:648)
	at java.awt.EventQueue.access$000(EventQueue.java:84)
	at java.awt.EventQueue$1.run(EventQueue.java:607)
	at java.awt.EventQueue$1.run(EventQueue.java:605)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)
	at java.awt.EventQueue$2.run(EventQueue.java:621)
	at java.awt.EventQueue$2.run(EventQueue.java:619)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:618)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:158)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 1 markiewb 2012-11-20 17:34:52 UTC
*** Bug 222462 has been marked as a duplicate of this bug. ***
Comment 2 markiewb 2012-11-20 17:37:43 UTC
Looks like a duplicate of 219894. Please vote there.

*** This bug has been marked as a duplicate of bug 219894 ***
Comment 3 Vladimir Voskresensky 2012-12-11 07:18:11 UTC
http://hg.netbeans.org/cnd-main/rev/4e9ff8f3956d
Comment 4 Quality Engineering 2012-12-12 02:46:27 UTC
Integrated into 'main-golden', will be available in build *201212120001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4e9ff8f3956d
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixed #221172 - !!WARNING!! Missing READ-LOCK when accessing TokenHierarchy from CompletionSupport.isIncludeCompletionEnabled


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo