Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 215884 - Unable to install into home
Unable to install into home
Status: NEW
Product: installer
Classification: Unclassified
Component: NBI
7.2
Sun Solaris
: P4 (vote)
: TBD
Assigned To: Libor Fischmeistr
issues@installer
: RELNOTE
: 231478 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 14:45 UTC by joergw
Modified: 2013-07-10 15:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Installer log file (174.92 KB, application/octet-stream)
2012-07-24 14:45 UTC, joergw
Details
Output of mount (stripped by restricted information) (2.91 KB, application/octet-stream)
2012-07-24 14:46 UTC, joergw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description joergw 2012-07-24 14:45:29 UTC
Created attachment 122304 [details]
Installer log file

After selecting the destination directory I got the error message "Base IDE ist set up to be installed to ... which does not belong to any of the filesystem roots.

I tried to install into my home directory, which is a NFS mount.

Installer log attached.
Comment 1 joergw 2012-07-24 14:46:45 UTC
Created attachment 122305 [details]
Output of mount (stripped by restricted information)
Comment 2 joergw 2012-07-24 14:57:09 UTC
I've installed the versions 7.0.1, 7.1 and 7.1.2 on this machine without this issue.
Comment 3 Libor Fischmeistr 2012-07-26 11:44:25 UTC
Probably caused by fix issue 214959
Comment 4 joergw 2012-07-27 05:20:13 UTC
With the workaround mentioned in issue 214959 (-J-Dno.space.check=true), it works for me.
Comment 5 Libor Fischmeistr 2012-09-24 08:51:09 UTC
Can you describe me how did you manage your mounted points? I need to reproduce this bug to fix it..
Comment 6 joergw 2012-10-01 06:13:47 UTC
What do you need to know in detail? On this machine, I'm not an administrator and don't manage anything. But I will ask admins what you want to know. I can provide some more diagnostic output, too.
Comment 7 Libor Fischmeistr 2012-11-12 08:16:34 UTC
This bug is very individual, we are unable to reproduce it.

It should be documented as a corner case...

Workaround exist's (thanks to joergw): use "-J-Dno.space.check=true" switch.
Comment 8 Libor Fischmeistr 2013-04-04 14:35:54 UTC
There were several changes in installer regarding to dealing with symlinks and paths.

Please if you are still able to reproduce this bug, try the new daily build and tell us if you issue is still valid.

Thanks
Comment 9 Libor Fischmeistr 2013-04-04 14:37:46 UTC
Changes I meant in previous comment: http://hg.netbeans.org/core-main/rev/8354c1b7bfc9
Comment 10 Libor Fischmeistr 2013-06-19 12:30:52 UTC
*** Bug 231478 has been marked as a duplicate of this bug. ***
Comment 11 vanob 2013-07-10 15:39:20 UTC
If somebody wants to reproduce this issue please do a clean install of Solaris 11.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo