Bug 215472 - 100% cpu with Lazy Node Children
100% cpu with Lazy Node Children
Status: RESOLVED DUPLICATE of bug 221279
Product: platform
Classification: Unclassified
Component: Nodes
7.3
PC Mac OS X
: P2 with 1 vote (vote)
: 7.3
Assigned To: Jaroslav Tulach
issues@platform
:
: 215686 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-12 15:21 UTC by Petr Jiricka
Modified: 2012-11-05 11:35 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Self-profiling snapshot (13.40 KB, application/octet-stream)
2012-07-12 15:21 UTC, Petr Jiricka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2012-07-12 15:21:49 UTC
Created attachment 121977 [details]
Self-profiling snapshot

I am attaching the profiler snapshot.

Product Version: NetBeans IDE Dev (Build EaselCSS-315-on-20120712)
Java: 1.7.0_06-ea; Java HotSpot(TM) 64-Bit Server VM 23.2-b04
System: Mac OS X version 10.7.4 running on x86_64; UTF-8; en_US (nb)
Comment 1 Jaroslav Tulach 2012-07-13 16:11:06 UTC
The thread running
org.netbeans.modules.project.ui.ProjectTab	
seems to take 12s of 12s execution.

There seems to be one call to
org.openide.loaders.FolderChildren.getNodes()	100.0	12 818 ms (100%)	12 818 ms	1
which then leads to many calls to
org.openide.nodes.Children.getNodes()	51.35032	6 582 ms (51,4%)	6 582 ms	314

Possibly bug in lazy node children.
Comment 2 Jaroslav Tulach 2012-08-10 17:13:40 UTC
One call to org.openide.loaders.FolderChildren.getNodes()	100.0	12 818 ms (100%)	12 818 ms	1
leads to 314 calls to org.openide.nodes.Children.getNodes()	51.35032	6 582 ms (51,4%)	6 582 ms	314
Comment 3 Jaroslav Tulach 2012-08-16 14:32:06 UTC
*** Bug 215686 has been marked as a duplicate of this bug. ***
Comment 5 Jaroslav Tulach 2012-10-24 12:55:24 UTC
If repeatable turn on logging: -J-Dorg.openide.loaders.FolderChildren.level=FINE, if not repeatable, I close as worksforme soon.
Comment 6 Jiri Skrivanek 2012-10-24 15:05:39 UTC
Please, look at log here (72 MB)

http://hudson4qe.cz.oracle.com/job/_Temp-215472/jdk=JDK%207,label=Ubuntu64-slave2/5/consoleText
Comment 7 Jaroslav Tulach 2012-10-31 07:19:23 UTC
More logging in ergonomics#396cf3d64e4e
Comment 8 Quality Engineering 2012-11-01 02:39:33 UTC
Integrated into 'main-golden', will be available in build *201211010001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/396cf3d64e4e
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #215472: More logging that automatically turns on and bails out (in ea mode) to find out what is going on
Comment 10 Jaroslav Tulach 2012-11-01 15:57:11 UTC
    [junit] WARNING [org.openide.loaders.FolderChildren..space.hudson.workspace._Temp-215472.jdk.JDK 7.label.Ubuntu64-slave2.testdistribution.qa-functional.work.org-netbeans-modules-java-kit.userdir0.SampleProject.src.sampleproject]: getNodes takes ages, turning on logging
    [junit] FINE [org.openide.loaders.FolderChildren..space.hudson.workspace._Temp-215472.jdk.JDK 7.label.Ubuntu64-slave2.testdistribution.qa-functional.work.org-netbeans-modules-java-kit.userdir0.SampleProject.src.sampleproject]: waitOptimalResult
    [junit] FINE [org.openide.loaders.FolderChildren..space.hudson.workspace._Temp-215472.jdk.JDK 7.label.Ubuntu64-slave2.testdistribution.qa-functional.work.org-netbeans-modules-java-kit.userdir0.SampleProject.src.sampleproject]: waitOptimalResult: waitProcessingFinished
    [junit] FINE [org.openide.loaders.FolderChildren..space.hudson.workspace._Temp-215472.jdk.JDK 7.label.Ubuntu64-slave2.testdistribution.qa-functional.work.org-netbeans-modules-java-kit.userdir0.SampleProject.src.sampleproject]: original before wait: org.openide.nodes.FilterNode[name=null][Name=SampleClass11, displayName=SampleClass11.java]
    [junit] FINE [org.openide.loaders.FolderChildren..space.hudson.workspace._Temp-215472.jdk.JDK 7.label.Ubuntu64-slave2.testdistribution.qa-functional.work.org-netbeans-modules-java-kit.userdir0.SampleProject.src.sampleproject]: original after wait: org.openide.nodes.FilterNode[name=null][Name=SampleClass11, displayName=SampleClass11.java]
    [junit] FINE [org.openide.loaders.FolderChildren..space.hudson.workspace._Temp-215472.jdk.JDK 7.label.Ubuntu64-slave2.testdistribution.qa-functional.work.org-netbeans-modules-java-kit.userdir0.SampleProject.src.sampleproject]: Waiting for delayed node org.openide.loaders.FolderChildren$DelayedNode[name=null][Name=SampleClass11, displayName=SampleClass11.java]
Comment 11 Jaroslav Tulach 2012-11-05 11:35:41 UTC

*** This bug has been marked as a duplicate of bug 221279 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo