Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 214460 - Removing method parameters refactoring fails
Removing method parameters refactoring fails
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
7.2
PC Linux
: P2 (vote)
: 7.2.1
Assigned To: Vladimir Voskresensky
issues@cnd
72patch1-verified
:
: 179963 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 17:05 UTC by vanob
Modified: 2012-09-04 09:09 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vanob 2012-06-19 17:05:36 UTC
[ BUILD # : 201206141830 ]
[ JDK VERSION : 1.7.4 ]

I have followed
http://wiki.netbeans.org/TS_67_CNDrefactoring

Removing method parameters

When I try to remove the freshly added parameter and press Preview, it says "No
patterns found".
And also If I press directly Refactor it does nothing.
Comment 1 Leonid Lenyashin 2012-06-19 20:56:11 UTC
Please evaluate
Comment 2 Vladimir Voskresensky 2012-06-19 21:54:33 UTC
http://hg.netbeans.org/cnd-main/rev/b55318f273d4
Comment 3 Alexander Pepin 2012-06-20 09:18:42 UTC
It's not a regression, (see bug# 179963)
Comment 4 Quality Engineering 2012-06-22 04:50:30 UTC
Integrated into 'main-golden', will be available in build *201206220002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/b55318f273d4
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixed #214460 - Removing method parameters refactoring fails
- check for changed number of parameters
Comment 5 vanob 2012-07-09 20:07:03 UTC
Reproducible in 201206291011.
Comment 6 vanob 2012-07-09 20:09:06 UTC
*** Bug 179963 has been marked as a duplicate of this bug. ***
Comment 7 soldatov 2012-07-10 07:46:38 UTC
(In reply to comment #5)
> Reproducible in 201206291011.
Do you speak about NetBeans 7.3 (nightly builds) or NetBeans 7.2 fcs?
Comment 8 vanob 2012-07-10 13:38:49 UTC
I'm talking about NetBeans 7.2 fcs
Comment 9 Alexander Pepin 2012-07-10 15:13:20 UTC
(In reply to comment #6)
> *** Bug 179963 has been marked as a duplicate of this bug. ***

Vano, thank you for your activity but you should not modify or close not your bugs. It's the responsibility of NB QA and Dev teams. Moreover it's not common to close an earlier opened bug as a duplicate of the latest one.
Comment 10 Alexander Pepin 2012-07-10 15:49:13 UTC
It's fixed in trunk.
Comment 11 vanob 2012-07-10 17:21:20 UTC
Alexander,

Sorry for my over activity.
I'll take that into account in the future.
Comment 12 Alexander Pepin 2012-07-11 12:44:44 UTC
Vano, no problem :)
Comment 13 Alexander Pepin 2012-08-30 12:55:18 UTC
The fix is verified in build 20120830.
Please integrate the fix into "release72" and change WB status to "72patch1-fixed"
Comment 14 Egor Ushakov 2012-08-31 12:08:42 UTC
integrated into release72:
http://hg.netbeans.org/releases/rev/3c4c3df54983
Comment 15 Quality Engineering 2012-09-01 11:06:55 UTC
Integrated into 'releases', will be available in build *201209010822* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/3c4c3df54983
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: fixed #214460 - Removing method parameters refactoring fails
- check for changed number of parameters
Comment 16 Alexander Pepin 2012-09-03 13:59:30 UTC
verified in 7.2 patch 1 build candidate 20120901
Comment 17 soldatov 2012-09-04 09:09:52 UTC
NetBeans 7.2 patch 1 has bug 215298
I think this fix breaks that test.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo