Bug 214180 - Ambiguous Html node in Navigator
Ambiguous Html node in Navigator
Status: RESOLVED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
7.2
All All
: P3 (vote)
: 7.4
Assigned To: Marek Fukala
issues@javaee
: REGRESSION
: 224976 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 08:59 UTC by Ondrej Brejla
Modified: 2013-08-23 02:36 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Navigator with Html node (38.22 KB, image/png)
2012-06-14 08:59 UTC, Ondrej Brejla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ondrej Brejla 2012-06-14 08:59:01 UTC
Created attachment 120816 [details]
Navigator with Html node

I have a Html node in Navigator, when I'm in a PHP file. Even though there is no HTML tag. It shouldn't be there.
Comment 1 Milutin Kristofic 2012-11-07 17:54:00 UTC
Reproducible in
Product Version: NetBeans IDE Dev (Build 201211010001)
Comment 2 Svata Dedic 2012-11-08 10:49:40 UTC
CSL gets a StructureItem for the HTML root from HTML embedding in PHP, the relevant Node in Html AST is ElementsFactory.VirtualOpenTag.

Moving to HTML for evaluation. One possible solution is not to provide virtual html tags for embeddings; CSL is not able to distinguish between the virtual tag, and an real, but leaf html tag in PHP source.
Comment 3 Jan Becicka 2012-11-09 14:02:52 UTC
Hm. Current html navigator is not CSL based. Maybe it is related to #221697
Comment 4 Marek Fukala 2012-11-09 15:33:47 UTC
this is not html.navigator module issue
Comment 5 Milutin Kristofic 2013-02-06 14:22:21 UTC
*** Bug 224976 has been marked as a duplicate of this bug. ***
Comment 6 Marek Fukala 2013-08-22 12:30:13 UTC
fixed in web-main#05ffc3cc81db
Comment 7 Quality Engineering 2013-08-23 02:36:26 UTC
Integrated into 'main-silver', will be available in build *201308222300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/05ffc3cc81db
User: Marek Fukala <mfukala@netbeans.org>
Log: #214180 - Ambiguous Html node in Navigator


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo