Bug 212246 - IllegalStateException: Somebody changed internal state meanwhile! Expected: Inited: true Thread: Thread[AWT-EventQueue-0,6,IDE Main] InProgress: true MustNotify: false Entries: 0; vis. entries: 0; Inf
IllegalStateException: Somebody changed internal state meanwhile! Expected: I...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Nodes
7.2
All All
: P2 (vote)
: 7.2
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
: 212618 212790 213659 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 14:51 UTC by schkovich
Modified: 2012-06-09 04:34 UTC (History)
12 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.60 KB, text/plain)
2012-05-09 14:51 UTC, schkovich
Details
stacktrace (2.16 KB, text/plain)
2012-05-24 15:50 UTC, Jesse Glick
Details
stacktrace (2.60 KB, text/plain)
2012-05-25 12:17 UTC, Ondrej Vrabec
Details
stacktrace (7.01 KB, text/plain)
2012-05-25 16:56 UTC, MackSix
Details
stacktrace (2.60 KB, text/plain)
2012-05-30 23:11 UTC, augcampos
Details
stacktrace (6.04 KB, text/plain)
2012-05-31 08:44 UTC, tim_sa
Details
stacktrace (6.91 KB, text/plain)
2012-06-04 11:28 UTC, Vladimir Riha
Details
stacktrace (7.44 KB, text/plain)
2012-06-04 13:07 UTC, augcampos
Details
stacktrace (6.51 KB, text/plain)
2012-06-05 23:16 UTC, Jesse Glick
Details
stacktrace (2.16 KB, text/plain)
2012-06-06 16:07 UTC, Martin Entlicher
Details
stacktrace (5.14 KB, text/plain)
2012-06-07 07:24 UTC, Martin Fousek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-05-09 14:51:28 UTC
Build: NetBeans IDE Dev (Build 201205090400)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: Opening a node in the file tree




Stacktrace: 
java.lang.IllegalStateException: Somebody changed internal state meanwhile!
Expected: Inited: true
Thread: Thread[AWT-EventQueue-0,6,IDE Main]
InProgress: true
MustNotify: false
Entries: 0; vis. entries: 0; Infos: 0; entriesSize: 0; entryToInfoSize: 0


current : Inited: true
Thread: null
InProgress: true
MustNotify: false
Entries: 0; vis. entries: 0; Infos: 0; entriesSize: 0; entryToInfoSize: 0


   at org.openide.nodes.EntrySupportLazy.setState(EntrySupportLazy.java:87)
   at org.openide.nodes.EntrySupportLazy.setEntries(EntrySupportLazy.java:500)
   at org.openide.nodes.EntrySupport.setEntries(EntrySupport.java:83)
   at org.openide.nodes.Children$Keys$2.run(Children.java:1556)
   at org.openide.util.Mutex$1Exec.run(Mutex.java:1246)
   at org.openide.nodes.Children$ProjectManagerDeadlockDetector.execute(Children.java:1921)
Comment 1 schkovich 2012-05-09 14:51:34 UTC
Created attachment 119215 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-05-15 08:14:28 UTC
This bug is also related to bug 212237, but the exception is coming from slightly different place. Not from setEntriesSimple, but from setEntries.
Comment 3 Jaroslav Tulach 2012-05-18 14:22:15 UTC
*** Bug 212618 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Tulach 2012-05-21 15:22:13 UTC
*** Bug 212790 has been marked as a duplicate of this bug. ***
Comment 5 Jesse Glick 2012-05-24 15:50:20 UTC
Created attachment 119831 [details]
stacktrace
Comment 6 Ondrej Vrabec 2012-05-25 12:17:36 UTC
Created attachment 119881 [details]
stacktrace
Comment 7 Exceptions Reporter 2012-05-25 12:17:52 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=187787
Comment 8 MackSix 2012-05-25 16:56:39 UTC
Created attachment 119897 [details]
stacktrace

Moved JFrame source file with Internationalization into default package.
Comment 9 augcampos 2012-05-30 23:11:48 UTC
Created attachment 120091 [details]
stacktrace
Comment 10 tim_sa 2012-05-31 08:44:46 UTC
Created attachment 120103 [details]
stacktrace

opened the IDE
Comment 11 Vladimir Riha 2012-06-04 11:28:13 UTC
Created attachment 120309 [details]
stacktrace

Expanding "Source Files" node in project window for just created PHP project (with Doctrine2 fw)
Comment 12 augcampos 2012-06-04 13:07:14 UTC
Created attachment 120315 [details]
stacktrace
Comment 13 Jesse Glick 2012-06-05 23:16:17 UTC
Created attachment 120399 [details]
stacktrace
Comment 14 Exceptions Reporter 2012-06-06 14:04:18 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=187787
Comment 15 Martin Entlicher 2012-06-06 16:07:14 UTC
Created attachment 120439 [details]
stacktrace

Thrown after IDE restart.
Comment 16 Jaroslav Tulach 2012-06-06 18:24:50 UTC
*** Bug 213659 has been marked as a duplicate of this bug. ***
Comment 17 Jaroslav Tulach 2012-06-06 19:41:30 UTC
ergonomics#9661b2ec3040
Comment 18 Martin Fousek 2012-06-07 07:24:33 UTC
Created attachment 120461 [details]
stacktrace
Comment 19 Quality Engineering 2012-06-09 04:34:02 UTC
Integrated into 'main-golden', will be available in build *201206090001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/9661b2ec3040
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #212246: Repeat whole setEntries, if the state was changed while the computation was running.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo