Bug 212237 - IllegalStateException: Somebody changed internal state meanwhile! Expected: Inited: false Thread: Thread[org.netbeans.modules.project.ui.ProjectTab,1,system] InProgress: true MustNotify: false Entries
IllegalStateException: Somebody changed internal state meanwhile! Expected: I...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Nodes
7.2
All All
: P1 (vote)
: 7.2
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
: 212273 212546 (view as bug list)
Depends on: 208589
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 13:18 UTC by Vladimir Riha
Modified: 2012-05-21 20:06 UTC (History)
46 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.76 KB, text/plain)
2012-05-09 13:18 UTC, Vladimir Riha
Details
stacktrace (4.42 KB, text/plain)
2012-05-09 13:29 UTC, Tomas Danek
Details
stacktrace (6.38 KB, text/plain)
2012-05-09 14:08 UTC, troodon
Details
stacktrace (6.29 KB, text/plain)
2012-05-09 15:20 UTC, Exceptions Reporter
Details
stacktrace (7.07 KB, text/plain)
2012-05-09 17:38 UTC, Michel Graciano
Details
stacktrace (4.13 KB, text/plain)
2012-05-09 22:08 UTC, Jesse Glick
Details
stacktrace (4.44 KB, text/plain)
2012-05-10 01:23 UTC, Jesse Glick
Details
stacktrace (2.12 KB, text/plain)
2012-05-10 09:17 UTC, Vladimir Voskresensky
Details
stacktrace (6.38 KB, text/plain)
2012-05-10 13:21 UTC, schkovich
Details
stacktrace (6.48 KB, text/plain)
2012-05-10 13:54 UTC, J Bachorik
Details
stacktrace (4.44 KB, text/plain)
2012-05-10 14:50 UTC, Jesse Glick
Details
stacktrace (4.20 KB, text/plain)
2012-05-10 14:57 UTC, Jiri Prox
Details
stacktrace (4.84 KB, text/plain)
2012-05-10 15:35 UTC, aldobrucale
Details
stacktrace (4.44 KB, text/plain)
2012-05-10 17:02 UTC, Michel Graciano
Details
stacktrace (4.46 KB, text/plain)
2012-05-10 17:36 UTC, javydreamercsw
Details
stacktrace (6.38 KB, text/plain)
2012-05-11 07:33 UTC, ehsavoie
Details
stacktrace (2.12 KB, text/plain)
2012-05-11 07:42 UTC, Vladimir Voskresensky
Details
stacktrace (4.20 KB, text/plain)
2012-05-11 09:53 UTC, Sergey Petrov
Details
stacktrace (4.20 KB, text/plain)
2012-05-11 11:42 UTC, Maksim Khramov
Details
stacktrace (7.07 KB, text/plain)
2012-05-11 15:06 UTC, MackSix
Details
stacktrace (4.33 KB, text/plain)
2012-05-11 17:47 UTC, Michel Graciano
Details
stacktrace (2.69 KB, text/plain)
2012-05-12 11:03 UTC, xamelion
Details
stacktrace (6.29 KB, text/plain)
2012-05-12 21:42 UTC, luislobo
Details
stacktrace (2.87 KB, text/plain)
2012-05-13 23:48 UTC, David Konecny
Details
stacktrace (2.69 KB, text/plain)
2012-05-14 02:30 UTC, David Konecny
Details
stacktrace (4.18 KB, text/plain)
2012-05-14 08:42 UTC, ytn01
Details
stacktrace (4.57 KB, text/plain)
2012-05-14 08:54 UTC, Stepan Zebra
Details
stacktrace (4.20 KB, text/plain)
2012-05-14 09:18 UTC, Jiri Kovalsky
Details
stacktrace (2.52 KB, text/plain)
2012-05-14 13:35 UTC, Martin Fousek
Details
stacktrace (2.52 KB, text/plain)
2012-05-14 14:00 UTC, MackSix
Details
stacktrace (6.38 KB, text/plain)
2012-05-15 08:48 UTC, Jiri Skrivanek
Details
stacktrace (5.22 KB, text/plain)
2012-05-15 09:42 UTC, Jiri Skrivanek
Details
stacktrace (4.62 KB, text/plain)
2012-05-15 09:54 UTC, ehsavoie
Details
stacktrace (2.52 KB, text/plain)
2012-05-15 10:45 UTC, Petr Cyhelsky
Details
stacktrace (4.46 KB, text/plain)
2012-05-15 13:09 UTC, javydreamercsw
Details
stacktrace (7.56 KB, text/plain)
2012-05-16 17:45 UTC, MackSix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2012-05-09 13:18:28 UTC
Build: NetBeans IDE Dev (Build 201205090400)
VM: Java HotSpot(TM) Client VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b20
OS: Linux

User Comments:
obrejla: Starting NB.

obrejla: Everytime I start a dev build.

vriha: creating new project




Stacktrace: 
java.lang.IllegalStateException: Somebody changed internal state meanwhile!
Expected: Inited: false
Thread: Thread[org.netbeans.modules.project.ui.ProjectTab,1,system]
InProgress: true
MustNotify: false
Entries: 2; vis. entries: 2; Infos: 2; entriesSize: 2; entryToInfoSize: 2
1 entry Children.Keys.KE[FolderChildren.Pair[/var/www/PhpProject7/nbproject@8170650c:270ab5,0],0] -> EntryInfo for entry: Children.Keys.KE[FolderChildren.Pair[/var/www/PhpProject7/nbproject@8170650c:270ab5,0],0], node: null
2 entry Children.Keys.KE[FolderChildren.Pair[/var/www/PhpProject7/index.php@ea164585:36d98a,0],0] -> EntryInfo for entry: Children.Keys.KE[FolderChildren.Pair[/var/www/PhpProject7/index.php@ea164585:36d98a,0],0], node: null


 contained EntryInfo for entry: Children.Keys.KE[FolderChildren.Pair[/var/www/PhpProject7/nbproject@8170650c:270ab5,0],0], node: null
 contained EntryInfo for entry: Children.Keys.KE[FolderChildren.Pair[/var/www/PhpProject7/index.php@ea164585:36d98a,0],0], node: null
current : Inited: true
Thread
   at org.openide.nodes.EntrySupportLazy.setState(EntrySupportLazy.java:87)
   at org.openide.nodes.EntrySupportLazy.setEntriesSimple(EntrySupportLazy.java:681)
   at org.openide.nodes.EntrySupportLazy.setEntries(EntrySupportLazy.java:458)
   at org.openide.nodes.EntrySupport.setEntries(EntrySupport.java:83)
   at org.openide.nodes.Children$Keys$2.run(Children.java:1556)
   at org.openide.util.Mutex$1Exec.run(Mutex.java:1246)
Comment 1 Vladimir Riha 2012-05-09 13:18:34 UTC
Created attachment 119203 [details]
stacktrace
Comment 2 Tomas Danek 2012-05-09 13:29:54 UTC
Created attachment 119204 [details]
stacktrace

just created java project
Comment 3 Exceptions Reporter 2012-05-09 13:47:54 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=187776
Comment 4 troodon 2012-05-09 14:08:53 UTC
Created attachment 119208 [details]
stacktrace
Comment 5 Exceptions Reporter 2012-05-09 15:20:55 UTC
Created attachment 119217 [details]
stacktrace
Comment 6 Michel Graciano 2012-05-09 17:38:54 UTC
Created attachment 119229 [details]
stacktrace
Comment 7 Jesse Glick 2012-05-09 22:08:57 UTC
Created attachment 119238 [details]
stacktrace

C-S-1
Comment 8 Jesse Glick 2012-05-10 01:23:58 UTC
Created attachment 119244 [details]
stacktrace

Opening ContactEditor form (from GUI examples).
Comment 9 Exceptions Reporter 2012-05-10 01:24:17 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=187776
Comment 10 Vladimir Voskresensky 2012-05-10 09:17:58 UTC
Created attachment 119258 [details]
stacktrace

restarted IDE
Comment 11 schkovich 2012-05-10 13:21:00 UTC
Created attachment 119284 [details]
stacktrace

Opening IDE. I guess that this is duplicate and already fixed: #212278
Comment 12 J Bachorik 2012-05-10 13:54:00 UTC
Created attachment 119290 [details]
stacktrace

opening the ide
Comment 13 Jesse Glick 2012-05-10 14:50:59 UTC
Created attachment 119297 [details]
stacktrace
Comment 14 Jiri Prox 2012-05-10 14:57:01 UTC
Created attachment 119298 [details]
stacktrace

ISE when starting IDE
Comment 15 aldobrucale 2012-05-10 15:35:58 UTC
Created attachment 119304 [details]
stacktrace

Created Glassfish descriptor in maven web project
Comment 16 Exceptions Reporter 2012-05-10 15:36:15 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=187776
Comment 17 Michel Graciano 2012-05-10 17:02:59 UTC
Created attachment 119311 [details]
stacktrace
Comment 18 javydreamercsw 2012-05-10 17:36:00 UTC
Created attachment 119312 [details]
stacktrace

During initial project scanning
Comment 19 ehsavoie 2012-05-11 07:33:00 UTC
Created attachment 119334 [details]
stacktrace
Comment 20 Vladimir Voskresensky 2012-05-11 07:42:00 UTC
Created attachment 119335 [details]
stacktrace

reopen IDE
Comment 21 Sergey Petrov 2012-05-11 09:53:59 UTC
Created attachment 119338 [details]
stacktrace

just start ide with simple project opened
Comment 22 Maksim Khramov 2012-05-11 11:42:00 UTC
Created attachment 119341 [details]
stacktrace
Comment 23 MackSix 2012-05-11 15:06:00 UTC
Created attachment 119360 [details]
stacktrace

Something really strange is going on here. 1) Restarted Computer 2) Started Netbeans 3) Java SE Project alread open 4) Opened up root node in Prjects Window, then a package node and this Exception was thrown.
Comment 24 Jaroslav Tulach 2012-05-11 15:37:39 UTC
setEntriesSimple can probably be executed in parallel with the other thread doing initialization of the node. The best solution is to repeat the action: e.g. compute the result for setEntriesSimple once again.
Comment 25 Michel Graciano 2012-05-11 17:47:59 UTC
Created attachment 119367 [details]
stacktrace
Comment 26 xamelion 2012-05-12 11:03:00 UTC
Created attachment 119381 [details]
stacktrace
Comment 27 luislobo 2012-05-12 21:42:01 UTC
Created attachment 119383 [details]
stacktrace

Opening Netbeans
Comment 28 David Konecny 2012-05-13 23:48:00 UTC
Created attachment 119394 [details]
stacktrace
Comment 29 David Konecny 2012-05-14 02:30:00 UTC
Created attachment 119395 [details]
stacktrace

I'm getting this one regularly after each IDE startup
Comment 30 ytn01 2012-05-14 08:42:01 UTC
Created attachment 119404 [details]
stacktrace
Comment 31 Stepan Zebra 2012-05-14 08:54:01 UTC
Created attachment 119407 [details]
stacktrace

Product Version: NetBeans IDE Dev (Build 201205130400)
Java: 1.7.0_04; Java HotSpot(TM) 64-Bit Server VM 23.0-b21
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)

Creating new JavaFX Application with Preloader.
Comment 32 Jiri Kovalsky 2012-05-14 09:18:02 UTC
Created attachment 119409 [details]
stacktrace

Opened JavaApplication1 project, opened test.tst file, created new watch, deleted the watch, closed the Watches view and restarted the IDE.
Comment 33 Martin Fousek 2012-05-14 13:35:59 UTC
Created attachment 119431 [details]
stacktrace
Comment 34 MackSix 2012-05-14 14:00:00 UTC
Created attachment 119432 [details]
stacktrace

1) Closed all projects. 2) Closed NetBeans. 3) Restarted NetBeans. 4) Opened Project that is causing this exception: http://netbeans.org/bugzilla/show_bug.cgi?id=209904 5) Clicked on Source Package node and then 1st package node to open them in Projects Windows and this Exception was thrown.
Comment 35 Jaroslav Tulach 2012-05-14 17:31:51 UTC
ergonomics#a958c27bf831
Comment 36 Jaroslav Tulach 2012-05-15 08:03:52 UTC
*** Bug 212273 has been marked as a duplicate of this bug. ***
Comment 37 Jiri Skrivanek 2012-05-15 08:48:01 UTC
Created attachment 119452 [details]
stacktrace

Thrown when creating new web project with GlassFish server.
Comment 38 Jiri Skrivanek 2012-05-15 09:42:00 UTC
Created attachment 119456 [details]
stacktrace

I restarted IDE.
Comment 39 ehsavoie 2012-05-15 09:54:00 UTC
Created attachment 119458 [details]
stacktrace
Comment 40 Petr Cyhelsky 2012-05-15 10:45:01 UTC
Created attachment 119459 [details]
stacktrace
Comment 41 javydreamercsw 2012-05-15 13:09:04 UTC
Created attachment 119474 [details]
stacktrace

IDE start up.
Comment 42 Quality Engineering 2012-05-16 11:18:05 UTC
Integrated into 'main-golden', will be available in build *201205160400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a958c27bf831
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #212237: Repeat the computation in setEntriesSimple, if there was a change in state meanwhile. Pass the stateHolder between individual methods to ensure consistency.
Comment 43 MackSix 2012-05-16 17:45:04 UTC
Created attachment 119541 [details]
stacktrace

Opened Tools>>Swing/Awt Components Palette Manager
Comment 44 Jaroslav Tulach 2012-05-18 08:14:50 UTC
*** Bug 212546 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo