Bug 210628 - java.util.ConcurrentModificationException at java.util.AbstractList$Itr.checkForComodification
java.util.ConcurrentModificationException at java.util.AbstractList$Itr.check...
Status: RESOLVED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Marek Fukala
issues@javaee
EXCEPTIONS_REPORT
:
: 210580 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 15:08 UTC by Marek Fukala
Modified: 2012-04-07 10:09 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.35 KB, text/plain)
2012-04-03 15:08 UTC, Marek Fukala
Details
stacktrace (5.68 KB, text/plain)
2012-04-04 11:02 UTC, Egor Ushakov
Details
stacktrace (5.68 KB, text/plain)
2012-04-04 20:29 UTC, Vladimir Voskresensky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Fukala 2012-04-03 15:08:53 UTC
Build: NetBeans IDE Dev (Build 20120330-1af99f09e439)
VM: Java HotSpot(TM) Client VM, 20.4-b02-402, Java(TM) SE Runtime Environment, 1.6.0_29-b11-402-10M3616
OS: Mac OS X

User Comments:
mfukala: type <a into an html file and invoke completion




Stacktrace: 
java.util.ConcurrentModificationException
   at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:372)
   at java.util.AbstractList$Itr.next(AbstractList.java:343)
   at org.netbeans.modules.html.parser.ElementsFactory$CommonOpenTag.removeChildren(ElementsFactory.java:432)
   at org.netbeans.modules.html.parser.ParseTreeBuilder.appendChildrenToNewParent(ParseTreeBuilder.java:496)
   at org.netbeans.modules.html.parser.ParseTreeBuilder.appendChildrenToNewParent(ParseTreeBuilder.java:77)
   at nu.validator.htmlparser.impl.TreeBuilder.adoptionAgencyEndTag(TreeBuilder.java:4484)
Comment 1 Marek Fukala 2012-04-03 15:08:56 UTC
Created attachment 117745 [details]
stacktrace
Comment 2 Egor Ushakov 2012-04-04 11:02:17 UTC
Created attachment 117802 [details]
stacktrace
Comment 3 Vladimir Voskresensky 2012-04-04 20:29:25 UTC
Created attachment 117842 [details]
stacktrace
Comment 4 Marek Fukala 2012-04-06 10:01:50 UTC
fixed in web-main#87b2daad4efa
Comment 5 Marek Fukala 2012-04-06 11:31:09 UTC
*** Bug 210580 has been marked as a duplicate of this bug. ***
Comment 6 Exceptions Reporter 2012-04-06 23:11:24 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=186614
Comment 7 Quality Engineering 2012-04-07 10:09:45 UTC
Integrated into 'main-golden', will be available in build *201204070400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/87b2daad4efa
User: Marek Fukala <mfukala@netbeans.org>
Log: #210628 - java.util.ConcurrentModificationException at java.util.AbstractList$Itr.checkForComodification


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo