Bug 208580 - NullPointerException at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.getExistingFor
NullPointerException at org.netbeans.modules.masterfs.filebasedfs.fileobjects...
Status: RESOLVED DUPLICATE of bug 209466
Product: platform
Classification: Unclassified
Component: Filesystems
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
: 208578 (view as bug list)
Depends on: 207060
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-17 16:25 UTC by Jesse Glick
Modified: 2012-03-16 15:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.68 KB, text/plain)
2012-02-17 16:25 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-02-17 16:25:28 UTC
Build: NetBeans IDE Dev (Build 20120217-07eeb50015fd)
VM: Java HotSpot(TM) Client VM, 21.1-b02, Java(TM) SE Runtime Environment, 1.7.0_01-b08
OS: Windows XP

Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.getExistingFor(BaseFileObj.java:1023)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.getExistingParentFor(BaseFileObj.java:1029)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.getExistingParent(BaseFileObj.java:1033)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.RefreshSlow.progress(RefreshSlow.java:103)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.RefreshSlow.refreshFileObject(RefreshSlow.java:93)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.refresh(FileObjectFactory.java:533)
Comment 1 Jesse Glick 2012-02-17 16:25:33 UTC
Created attachment 115887 [details]
stacktrace
Comment 2 Jesse Glick 2012-02-17 16:28:20 UTC
*** Bug 208578 has been marked as a duplicate of this bug. ***
Comment 3 Jaroslav Tulach 2012-03-16 15:53:45 UTC
Looks like duplicate of bug 209466: seems to be caused by null factory.

*** This bug has been marked as a duplicate of bug 209466 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo