Bug 208578 - UNC: NPE from BaseFileObj.getExistingFor
UNC: NPE from BaseFileObj.getExistingFor
Status: RESOLVED DUPLICATE of bug 208580
Product: platform
Classification: Unclassified
Component: Filesystems
7.2
PC Windows XP
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-17 15:34 UTC by Jesse Glick
Modified: 2012-02-17 16:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Log file (39.95 KB, application/octet-stream)
2012-02-17 15:34 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-02-17 15:34:46 UTC
Created attachment 115884 [details]
Log file

Recent dev build running on XP on a j2seproject in a UNC share.

SEVERE [org.openide.util.RequestProcessor]: Error in RequestProcessor org.netbeans.core.ui.warmup.MenuWarmUpTask$NbWindowsAdapter
java.lang.NullPointerException
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.getExistingFor(BaseFileObj.java:1023)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.getExistingParentFor(BaseFileObj.java:1029)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.getExistingParent(BaseFileObj.java:1033)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.RefreshSlow.progress(RefreshSlow.java:103)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.RefreshSlow.refreshFileObject(RefreshSlow.java:93)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.refresh(FileObjectFactory.java:533)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.refresh(FileObjectFactory.java:508)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.refreshAll(FileObjectFactory.java:440)
Comment 1 Jesse Glick 2012-02-17 15:36:14 UTC
(Would have used exception reporter but when I clicked on the error icon no dialog would appear - not sure why.)
Comment 2 Jesse Glick 2012-02-17 16:28:20 UTC
Now exc rep works.

*** This bug has been marked as a duplicate of bug 208580 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo